けいじゅ@いしつかです.

ruby-devに irb 0.9.5 をリリースして一週間ほどたちましたがそれほど,
(私的には)問題は出ていないようです.

問題の一つは, 

class SLex
end

だったのが,

module IRB
  class SLex
  end
end

になって, 問題が発生しているようです. そこで, 1.8.3 用の方では,
irb/slex.rbに

SLex=IRB::SLex

を入れてリリースしようと思っています.

# でも, irb/slex.rb を直接使っているものがあるとは思いもしませんでした.
# irb/ruby-lex.rb のブランチなんですかね?
# それはともかく,

他に何か問題などなければ, 今日にでも 1.8.3ブランチでもリリースしよう
と思っています.


__
---------------------------------------------------->> 石塚 圭樹 <<---
---------------------------------->> e-mail: keiju / ishitsuka.com <<---