こんにちは、sheepman です。

HEAD では cgi-lib.rb と getopts.rb と parsearg.rb と importenv.rb は require すると

  deprecated after Ruby 1.8.1

という警告が出ますが、 ruby-1.8.2 でも deprecated になっていません。
require しても警告がでません。

HEAD か ruby-1.8.2 のどちらかが間違っているんだと思います。

-- 
sheepman / TAMURA Takashi
sheepman / tcn.zaq.ne.jp http://sheepman.parfait.ne.jp/