前田です。

Yukihiro Matsumoto wrote:
>  (1) 現在、each_lineのaliasになっているeachを変更するのは互
>      換性問題が少々。

M17N化のどさくさにまぎれて...と考えましたが、やっぱり困る人もいるでしょ
うね。

>  (2) M17N的な"character"ってのはコードポイント(に対応するバ
>      イト列)ですから、たとえば合成文字の場合一部分だけを表現
>      するものもcharacterになってしまいます。こういうものを堂々
>      とcharと呼んではいけないような気もします。なんか言い名
>      前ないかな。

each_codepointというのもあんまりですよね。

> |今だと、s.split(//).all? { ... }とかしたりしているのですが、何だかなあ、と。
> 
> 適切な名前があれば、そのような機能を導入することは良いことだ
> と思います。

互換性の問題がないのは、String#all_char?, String#collect_charみたいなの
をたくさん用意してしまうことですね。
ただ、それもどうかなあ...。

-- 
前田 修吾