こんにちは、なかむら(う)です。

In message "[ruby-dev:23996] Re: String#each -> String#each_char"
    on Jul.30,2004 17:20:26, <matz / ruby-lang.org> wrote:
|  (2) M17N的な"character"ってのはコードポイント(に対応するバ
|      イト列)ですから、たとえば合成文字の場合一部分だけを表現
|      するものもcharacterになってしまいます。こういうものを堂々
|      とcharと呼んではいけないような気もします。なんか言い名
|      前ないかな。
| 
| |今だと、s.split(//).all? { ... }とかしたりしているのですが、何だかなあ、と。
| 
| 適切な名前があれば、そのような機能を導入することは良いことだ
| と思います。

むしろ、今のM17Nにある、各コードポイントをブロックに渡してく
るString#each_charではなくて、文字列中の各「1文字」をRubyの文
字列として渡してくるメソッドを作成してそれをeach_charと呼ぶと
いうのはどうでしょうか?

あんまりM17Nについてわかってないので勝手なことを言っています
が、それじゃいろいろ問題があるから今のString#each_charのよう
になってるのでしょうか。
# そうだろうなあ...


それでは。
-- 
U.Nakamura <usa / garbagecollect.jp>