まつもと ゆきひろです

In message "[ruby-dev:22788] relative load/require (Re:  Re: $: trick in test/*)"
    on 04/01/30, Tanaka Akira <akr / m17n.org> writes:

|> 上ではloadと書きました。requireとは別物にした方が良いのでは
|> ないでしょうか。
|
|どういうように別物になることを想定しているのでしょうか?

つまり、

  * 相対パスのロードは推奨されない
  * 相対パスで読み込むのは.soファイルではない

だろうからrequireに機能を追加しない方が良いだろうということ
です。

|ふむ。require も $" にはフルパスで記録するというのはどうでしょう?

これは良いアイディアだと思います。時間が取れたら実装します。