まつもと ゆきひろです

In message "[ruby-dev:22534] Re: can't require"
    on 04/01/07, nobu.nakada / nifty.ne.jp <nobu.nakada / nifty.ne.jp> writes:

|です。こんな感じ。

「こんな感じ」が妥当かどうかは山本さんに判断してもらおうと思
います。ただ、

|+#define GLOB_DEPTH	0x0100

という名前はあんまり良くないのでGLOB_DEPTHFIRSTとかにしても
らった方が良さそう。

|あと、Dir.openも継承されたときサブクラスのinitializeを呼ぶよう
|になってます。

あ、これはどうなんだっけ。newを経由しない時にはinitializeを
呼ばないやつもいたような気がしたので、いつかは調べて揃えない
といけませんね。