前田です。

At Wed, 19 Nov 2003 22:45:05 +0900,
matz / ruby-lang.org (Yukihiro Matsumoto) wrote:
> |こういうコード(内側のブロックで同じ名前の変数を再定義するコード)
> |はエラーになった方が好ましいように思うのですが、いかがでしょうか?
> 
> 私も(前田さんも)それは良くないスタイルだと信じているのですが、
> そうでない人はかなり多いようです。困ったもんだ。で、そういう
> 人たちを一生懸命説得するのも不毛なので、警告だけはするという
> ことを考えてます。

うーん、そういう消極的理由であれば、なおさらエラーの方がよいと思
います。

まつもとさんが「そういう人たち」を説得しなければならないというの
は逆で、むしろ「そういう人たち」がまつもとさん(や他の良識ある人々)
を説得するべきなんじゃないでしょうか。
現在のRubyの仕様では変数のhideはできないわけですから。

あと、「そういう人たち」の中にも「警告が出るくらいならエラーの方
がいい」という人がいるんじゃないでしょうか。

-- 
前田 修吾
ってruby-talkで議論しないといけないのかもしれないですけど…。