岩月と申します。

Yukihiro Matsumoto wrote:
> knuさんの紹介でFreeBSDマシンをお借りしたのですが、以下の環境
> では再現しませんでした。より詳細な情報を希望します。
> 
> FreeBSD 5.1-CURRENT i386
> FreeBSD 5.1-CURRENT sparc64
> 
> 4.8-RELEASEでないといけないのかな。

手元のFreeBSD 4.9-STABLE i386(昨日あたりにcvsupしてアップデートしたもの)
で試しました。Ruby は 1.8.1 preview2 (ports-current)です。

数十回連続で試したところ、ほとんどがエラーになりますが、稀に正常な結果が
返ることもあります。

lemmy:~/ruby/src/ruby-current/ext/pty% ruby -v expect_sample.rb
ruby 1.8.1 (2003-10-31) [i386-freebsd4]
The latest ruby interpreter is ruby-1.8.0.tar.gz

-- 
IWATSUKI Hiroyuki <don / na.rim.or.jp>