In message <20030724051319.A927910609 / ruby.jpn.hp.com>,
 `WATANABE Tetsuya <tetsu / jpn.hp.com>' wrote:
> ------------------------------
> #if defined(__GNUC__) || __STDC_VERSION__ >= 199901L
> ------------------------------
> 
> となっている場合 GCC ではすべて OK になってしまうので、GCC の 
> VERSION 指定を入れたほうがいいように思います。
> 
> でで、GCC のいつのバージョンからサポートなのか確認がとれなかったの
> ですいません。多くのプラットフォームでコンパイルできるように対応お
> 願いします。

gcc のバージョンを調べるよりも extconf.rb で __VA_ARGS__ の
存在を調べるのがいいと思うのですが、どう書くのがよいでしょう。

-- 
ごとうゆうぞう