まつもと ゆきひろです

dRuby方面には迷惑になるのは目に見えているのですが、Marshalの
マイナーバージョンをあげてもよいですか?

具体的には_dump()が文字列以外の任意のオブジェクトを返せるよ
うにしようと思います。今までは_dump()を作るのは大変でした(内
部でMarshal.dump()を呼ぶことを勧めていたけど、これでは循環に
対応するのが難しいし)。これで簡単になると思います。

マイナーバージョンをあげるとdRubyの利用者はバージョンを揃え
る必要がでてきますが、幸い(?)なことに、現状の1.8のMarshalバー
ジョンはすでに4.8で、1.6の4.6とは違ってしまっていますから、
1.8の正式リリースに合わせてのバージョンアップは被害が最少で
済むと思います。

いかがでしょうか?

1.8は7月中に出します。でないと次のMacOS X(Pantherだっけ)に間
に合わないそうなので。このライブラリを追加したいというような
話は、早めにお願いします。

現時点でscanf.rbが候補に挙がっています。