なかだです。

At Tue, 24 Jun 2003 13:50:39 +0900,
Tadashi Saito wrote:
> > > 「bigdecimal-rationalがrequireされるのは
> > > bigdecimalとrationalの双方がrequireされた後でなければならない」
> > > という事でしたら、順番を間違えたらLoadErrorにする方が明確になって
> > > 親切かと思い、その変更も付け加えてみました。
> >
> > その二つをrequireするとなにかまずい理由があるんでしょうか。
> 
> いや、するとまずいことはないです。「しないと」まずいのかな、と勝手に
> 想像してしまいました。
> 
> 今のままですと、[ruby-dev:20410]のように、bigdecimal-rationalが
> 他の二つのライブラリより早くrequireされると、警告が出たりエラーで終了
> したりしてしまいます。
> 
> これは作者の小林さんが、bigdecimal-rationalが最後にrequireされる事を
> 意図されているのかなということを、勝手に想像してしまいました。

ということであればbigdecimal-rational.rbの最初に

  require 'bigdecimal'
  require 'rational'

を追加するのが一番素直な解決策だと思うのですが、それだとなにか
まずいのだろうか、ということです。

-- 
--- 僕の前にBugはない。
--- 僕の後ろにBugはできる。
    中田 伸悦