よしだです

matz / ruby-lang.org (Yukihiro Matsumoto) writes:
> 1.6系最後の安定版(希望)の1.6.8のpreview4を出しました。
>
>   ftp://ftp.ruby-lang.org/pub/ruby/1.6/ruby-1.6.8-preview4.tar.gz
>
> です。問題を発見された方はお早めにレポートを、よろしく。


Solaris 8 ですが,--enable-ipv6 しても IPv6 が有効になりません。
ext/socket/extconf.rb の中の try_link,try_run で libsocket,
libnsl がリンクされないため,IPv6 の検出に失敗しているようです。

try_link,try_run で $libs を参照すべきだと思いますがどうで
しょう?

-- 
    吉田正人
    yoshidam / yoshidam.net