ふなばです。

> |1.7 で、#indexes をつかうと、#select をつかえと言われますが、rb_warn 
> |で、毎々で主張される程のことでもないような気もします。それで、どのよう
> |な場合に rb_warn が選択されるのか、方針があれば聞きたいのですが。
> 
> 1.8.1あたりでなくなりそうなメソッドを使った場合にrb_warnを使っ
> てます。あと、明確にエラーなんだけど、互換性の関係でしばらく
> は今の挙動を保存する必要がある場合にも。

安定版 1.8.0 で登場して、1.8.1 までに徹底させるということですか。1.8 
に移行したときに警告出まくりでイヤになりはしなか、というのは心配のしす
ぎなのだろうか。