まつもと ゆきひろです

In message "[ruby-dev:16271] Re: pstore.rb and sync.rb"
    on 02/03/08, Shugo Maeda <shugo / ruby-lang.org> writes:

|> たぶん、するならKernel.initialize_for()をなにもしないメソッ
|> ドにしておいて、それを呼ぶという実装にすると思います。
|
|Module#initialize_forでなくてKernel.initialize_forなんです?

えーと、間違いです。すいません。

|Moduleオブジェクトにinitialize_forを持っているかどうかのフラグを
|持たせて、フラグのチェックくらいのコストに押さえることはできない
|ですかね。
|# 今度はフラグの更新のコストが問題になりそうですが。

あんまり特別扱いを増やしたくないんですよねえ。すでに
initializeなど特別扱いはあるわけですが。

|> あと、initialize_for()って名前(「動詞+前置詞」パターン)はあ
|> んまり好きな名前じゃないです。
|
|extend_objectにならって、initialize_objectとか。

「動詞+前置詞」の問題はなくなりますが、こんどは「なぜモジュー
ルのinitialize_objectだけが呼ばれるのか」という疑問を呼びそ
うな。やはり名前は難しい。