前田です。

At Mon, 4 Mar 2002 13:42:59 +0900,
Akinori MUSHA <knu / iDaemons.org> wrote:
>  ただ、三つ目の数字("teeny")が一桁という制約は主にライブラリの
> バージョンを生成する目的からでしたよね?とすれば、少し前の議論に
> あったように、共有ライブラリ番号を Ruby のリリースバージョンと
> 独立にインターフェースの変更ベースで管理していけばこの制約は
> 外せると思うんですが、いかがでしょうか?

二桁を許すと、

if RUBY_VERSION >= "1.6.6"
  ...
end

ができなくなるという問題もありますね。

それはさておき、共有ライブラリのバージョンをRubyのバージョンと分
けるのは賛成です。
# OS間の違いを考えるとlibtoolを使うのが楽でしょうか。

-- 
前田 修吾