前田です。

In message "[ruby-dev:1509] Re: flock -> lock"
Yukihiro Matsumoto <matz / netlab.co.jp> wrote:

||File#flockについてなのですが、lockというメソッド名にした方が
||オブジェクト指向的(という言い方は変?)ではないでしょうか。
||File#getsもfgetsではなくgetsですし...。
|
|一見その通りなのですが,実はこれは「lockfでない」という意味
|あいがあってflockなのです.ので,このままで.

なるほど、了解です。

-- 
前田 修吾