前田です。

File#flockについてなのですが、lockというメソッド名にした方が
オブジェクト指向的(という言い方は変?)ではないでしょうか。
File#getsもfgetsではなくgetsですし...。

あと、

  def lock(operation = LOCK_EX)
    ...
  end

  def unlock
    lock(LOCK_UN)
  end

となっていると便利だと思いますが、いかがでしょう。
# unlockはあまり使わないかな。

-- 
前田 修吾