けいじゅ@日本ラショナルソフトウェアです.

In [ruby-dev :14777 ] the message: "[ruby-dev:14777] Re:
forwardable.rb : call Kernel.raise ", on Sep/12 16:50(JST) Yukihiro
Matsumoto writes:

>まつもと ゆきひろです

>|うーん. その再定義されたraiseは、オリジナルのraiseと違う目的なんですか? 
>|違う目的なら名前を変えるべきだし、同じ目的なら、オリジナルのraiseと同じ
>|振る舞いをすべき、つまり、こちらがraiseを呼んでも問題ないようにすべきだ
>|と思いますが?
>
>まあ、Tkのraiseのように元々のライブラリが提供している名前が
>raiseなので、raiseこそが(オリジナルのraiseとは意味が違うにし
>ても)最も適切な名前というケースもありえますから、いずれにし
>てもKernel::raise にしておいた方が良いように思います。

まあ, 普通のクラスライブラリと違って, クラスにextendして使うものだしね. 
了解しました. そうすることにしましょう.

__
..............................石塚 圭樹@日本ラショナルソフトウェア...
----------------------------------->> e-mail: keiju / rational.com <<---