まつもと ゆきひろです

In message "[ruby-dev:14766] Enumerable#inject"
    on 01/09/10, OZAWA -Crouton- Sakuro <crouton / weatherlight.org> writes:

|確かにSmalltalkの-ect兄弟としてはこの名前であるべきなのでしょうけど、やは
|りこの名前は直感的ではない気がします。

「直感的でない」という私的には同意します。

|C++だと、accumulateという名前でほぼ同義の動作をするものがあるのですが、こ
|れを別名として採用するのはいかがでしょうか?

PythonやLisp(MLも?)の世界ではreduceという別名が一般的のよう
です。accumulateとはかなり語感が違いますが。ちょうどDave
Thomasたちと一緒にいるので後で聞いてみます。