青木@横浜です。

Yukihiro Matsumoto wrote:
> |rb_require() つまり rb_f_require() には *.so でないスタティックリンクされている
> |拡張ライブラリを require するパスがないのです。今だと、
> |ファイルがないとエラーになります。拡張ライブラリ自体は miniruby
> |じゃない ruby だと常に初期化されますが、digest/md5 とかが rb_require("digetst")
> |するのでそこでエラーになるのです。
> むむむ、ここがバグですね。直しておきます。

ChangeLog より
|Tue Aug 28 00:40:48 2001  Yukihiro Matsumoto  <matz / ruby-lang.org>
|	* eval.c (rb_f_require): should check static linked libraries
|	  before raising exception.
にて DJGPP 版は問題なく動くようになりました。

# [ruby-dev:14607] の方は試していませんけど。

-- 
青木大輔 <dai / y7.net>