<199802100733.QAA04028 / eban.ase.ptg.sony.co.jp> の、
   "[ruby-dev:1420] Re: GD" において、
   "WATANABE Hirofumi <watanabe / ase.ptg.sony.co.jp>"さんは書きました:

> :D:\Free\ruby\GD-0.5>ruby -e "require 'GD'"
> :LoadLibraryExA
> :-e:1:in `require':  - ./GD.dll (LoadError)
> :        from -e:1
> :
> :なんていいます。
> 
> ruby のバージョンは?

ruby 1.1b6(98/01/23) [i386-cygwin32]

です。


> :「RUBY.EXE ファイルは
> :  欠落エクスポート CYGWIN.DLL:seteuid にリンクされています。」
> 
> これは pc/cygwin18.zip の cygwin.dll じゃなくてオリジナルの
> ほうを使ってるからかな? なんかあっちこっちに cygwin.dll が
> あるような気がするので, cygwin18.zip の cygwin.dll だけを使
> うようにしてください.

色んなところにありました (^_^;)
すみません。

で、C:\Windows\System にだけ cygwin18.zip の cygwin.dll を
残したら、上記のダイアログは出なくなりました。

D:\Free\ruby>ruby -e "require 'GD'"
LoadLibraryExA
-e:1:in `require':  - //d/free/ruby/gw/lib/GD.dll (LoadError)
        from -e:1

は、まだ出ます……。

M.Kanemitsu