まつもと ゆきひろです

In message "[ruby-dev:13717] Re: eval(code, true, filename)"
    on 01/07/01, Shugo Maeda <shugo / ruby-lang.org> writes:

|bindingとwrapの指定は排他的でいいかなと思ったのですが、いっそのこと
|bindingにwrapperの情報を持たせる(本来そうであるべきかも)ようにして、
|wrapper_binding(名前はもっといいのがあるかもしれませんが)でwrapper用
|のbindingを返すようにするというのはどうでしょうか。

bindingのwrapperの情報を持たせることには賛成です。
wrapper_bindingは名前の観点から反対です。

wrapするメソッドを作ってそこでbindingを得るというAPIが良さそ
うです。名前は...なにかいいのがありませんかねえ。

   wrapper_binding = Module.new.wrap{binding}

とか...

                                まつもと ゆきひろ /:|)