なかだです。

At Wed, 27 Jun 2001 02:02:16 +0900,
Minero Aoki <aamine / mx.edit.ne.jp> wrote:
> >   1.6、1.7 ともに -w をつけると net/http.rb で warning が出ます。
> 
> ども。なおしときます。

  今度は別のが出ますが、あらためて lib の下を調べてみたら結構あ
りますね。まぁ大体カッコを付ければいいだけみたいだしどうでもい
いですが、matrix.rb だけちょっと不思議な書き方。

lib/irb/multi-irb.rb:93: warning: catch (...) interpreted as method call
lib/irb/multi-irb.rb:93: warning: EXISTS (...) interpreted as command call
lib/irb/locale.rb:65: warning: `*' interpreted as argument prefix
lib/irb/locale.rb:75: warning: `*' interpreted as argument prefix
lib/mkmf.rb:38: warning: `*' interpreted as argument prefix
lib/shell/command-processor.rb:244: warning: `&' interpeted as argument prefix
lib/shell/command-processor.rb:254: warning: `&' interpeted as argument prefix
lib/shell/command-processor.rb:355: warning: eval (...) interpreted as method call
lib/shell/command-processor.rb:357: warning: d (...) interpreted as method call
lib/shell/command-processor.rb:393: warning: d (...) interpreted as method call
lib/shell/command-processor.rb:399: warning: d (...) interpreted as method call
lib/matrix.rb:222: warning: useless use of self in void context
lib/matrix.rb:900: warning: useless use of a literal in void context
lib/parsearg.rb:76: warning: ambiguous first argument; make sure

-- 
--- 僕の前にBugはない。
--- 僕の後ろにBugはできる。
    中田 伸悦