須貝です。
おさわがせしました。

At Fri, 1 Sep 2000 20:08:08 +0900,
Katsuyuki Komatsu wrote:
> 
> この場合、DLLの名前がruby-1.6.0.cygwin.dllになるので、
> DLLの名前に"-"が入ると落ちるcygwinのバグに引っかかった
> ものと思われます。
> "-1.6.0"ではなく、".1.6.0"とすると通りますし。

このバグって、たぶん cygwin 1.1.3 or 1.1.4 のバグなのですね。

ruby 1.5.5 をコンパイルしたときは、 cygwin 1.1.2 あたりの
スナップショットを使っていたみたいです。

なので DLL の名前が ruby-1.5.5.cygwin.dll になっていても
動いたのだと思います。
(現象にあったのが職場で、今、家にいるのでちょっと不確かですが。)

ためしに、家の cygwin 1.1.0 の環境だと、 DLL が
ruby-1.5.5.cygwin.dll でも動いたのできっとそうですよね。

ともかく、まぎらわしくてもうしわけなかったです。

--
須貝 典彦