小松です。

この、
  ruby lib version (1.5.5) doesn't match executable version (1.6.0)
の問題 ([ruby-dev:10513]のスレッド参照) はまだ対処されて
いないんですね。

% ./ruby-1.6.0 -v ruby 1.6.0 (2000-08-24) [sparc-solaris2.5.1] % sudo mv /usr/local/lib/ruby/1.5 /usr/local/lib/ruby/1.6 % sudo mv /usr/local/lib/ruby/site_ruby/1.5 /usr/local/lib/ruby/site_ruby/1.6 % sudo make install ← 1.5に上書きインストール ./miniruby ../instruby.rb /usr/local/lib/ruby/1.6/sparc-solaris2.5.1/rbconfig.rb:5: ruby lib version (1.5.5) doesn't match executable version (1.6.0) (RuntimeError) from ../instruby.rb:3:in `require' from ../instruby.rb:3 *** Error code 1 make: Fatal error: Command failed for target `install' % sudo rm /usr/local/lib/ruby/1.6/sparc-solaris2.5.1/rbconfig.rb % sudo make install ← 古いrbconfig.rbを消すとOK ./miniruby ../instruby.rb ... chmod 0644 /usr/local/lib/ruby/1.6/sparc-solaris2.5.1/libruby-1.6.0.a config.h -> /usr/local/lib/ruby/1.6/sparc-solaris2.5.1/config.h chmod 0644 /usr/local/lib/ruby/1.6/sparc-solaris2.5.1/config.h rbconfig.rb -> /usr/local/lib/ruby/1.6/sparc-solaris2.5.1/rbconfig.rb chmod 0644 /usr/local/lib/ruby/1.6/sparc-solaris2.5.1/rbconfig.rb % -- 小松克行 / Katsuyuki Komatsu <komatsu / sarion.co.jp>