まつもと ゆきひろです

In message "[ruby-dev:10151] Re: [ruby-list:23495] Re: Ruby 1.4.5"
    on 00/06/30, Wakou Aoyama <wakou / fsinet.or.jp> writes:

|> 1.4系のcgi.rbをfreezeして1.5系のみメンテする。今後cgi.rbは
|> block_given?を使うということでどうでしょう。
|
|という事は、ruby 1.6 をおすすめする。という事ですね。では、1.4 系につ
|いては cgi.rb 1.7.0 を使ってくれという事にして、新版は block_given? を
|使用して、ruby 1.5.4 より前のバージョンの場合には、例外で止めるという
|事で良いでしょうか?

それに賛成します。