青山です。

On Wed, 28 Jun 2000 09:15:41 +0900,
matz / netlab.co.jp (Yukihiro Matsumoto) wrote:

> 1.4系のcgi.rbをfreezeして1.5系のみメンテする。今後cgi.rbは
> block_given?を使うということでどうでしょう。

という事は、ruby 1.6 をおすすめする。という事ですね。では、1.4 系につ
いては cgi.rb 1.7.0 を使ってくれという事にして、新版は block_given? を
使用して、ruby 1.5.4 より前のバージョンの場合には、例外で止めるという
事で良いでしょうか?

raise "Please, use ruby1.5.4 or later." if RUBY_VERSION < "1.5.4"


-- 
青山 和光 Wakou Aoyama <wakou / fsinet.or.jp>