青山です。

On Sun, 25 Jun 2000 07:02:36 +0900,
Wakou Aoyama <wakou / fsinet.or.jp> wrote:

> > |lib/cgi.rbがCVSのバージョンより古いです。
> > 
> > cvs updateのwarningの意味はそういうことか、分かってませんで
> > した。修正します。

あ、なるほど。後から追加したので、cvs とは連動していなかったんですね。
ところで、1.5 系の cgi.rb では block_given? に統一されたようですが、こ
のままだと 1.4 系では動きませんが、どうしましょうか?

1.5 系のライブラリすべてを一括変換したようでも無さそうですが、1.6 のリ
リースまでには、すべてのライブラリを block_given? に統一するとしたら、
それらはやはり 1.4 系では動かなくなりますが、まあ、collect! も 1.4 系
には無いし、という事で、一気に乗り換えでしょうか。

と思ったら、1.4.5 には collect! があるんですね。とすると、選択肢として
は、こんな感じでしょうか。

* 1.4.6 に block_given? を含め、1.4 系を使いたい人にはそちらをすすめる
* 各ライブラリで、1.4 系では iterator? で代用するような仕組みを提供する
* 1.6 系をおすすめする事にする


-- 
青山 和光 Wakou Aoyama <wakou / fsinet.or.jp>