前田です。

At Tue, 13 Jun 2000 23:56:37 +0900,
Wakou Aoyama <wakou / fsinet.or.jp> wrote:
> 解決しました。
> 
> Apache/1.3.9 (Unix) Debian/GNU mod_ruby/0.1.8 Ruby/1.5.4(2000-06-13) 問題無し
> Apache/1.3.9 (Unix) Debian/GNU mod_ruby/0.1.8 Ruby/1.4.4(2000-06-05) 問題無し

ひょっとすると以下の(かなりはずかしい)バグの影響かもしれませんの
で、試していただけます?

diff -u -r1.7 apachelib.c
--- apachelib.c	2000/05/24 04:59:00	1.7
+++ apachelib.c	2000/06/14 03:18:53
@@ -452,7 +452,7 @@
 	strcasecmp(key, "proxy-authorization") == 0)
 	return Qnil;
     Data_Get_Struct(self, request_data, data);
-    val = ap_table_get(data->request->headers_in, STR2CSTR(key));
+    val = ap_table_get(data->request->headers_in, key);
     return val ? rb_str_new2(val) : Qnil;
 }
 

-- 
前田 修吾