Issue #17163 has been reported by sawa (Tsuyoshi Sawada).

----------------------------------------
Feature #17163: Rename `begin`
https://bugs.ruby-lang.org/issues/17163

* Author: sawa (Tsuyoshi Sawada)
* Status: Open
* Priority: Normal
----------------------------------------
`Range#begin` is a getter method; it returns a value, and does not have a side effect, or does any calculation. Nevertheless, "begin" is a verb, so there is a mismatch. I would rather expect a noun.

It has a counterpart `Range#end`, and "end" is a noun as well as a verb, so that is not strange.

I propose to alias `Range#begin` to a noun or a nominal. "beginning" will work, but it may be too long, so what about "start", which works as a noun (as well as a verb)?

```ruby
Range#start
```



-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>