Issue #17136 has been updated by matz (Yukihiro Matsumoto).


We waited enough long time. Let us remove it.

Matz.


----------------------------------------
Feature #17136: Remove special behavior from $KCODE
https://bugs.ruby-lang.org/issues/17136#change-87302

* Author: znz (Kazuhiro NISHIYAMA)
* Status: Open
* Priority: Normal
----------------------------------------
`$SAFE` is now a normal global variable with no special behavior.
I think `$KCODE` is no longer needed special behavior too.
Warnings since 1.9. 

```
% docker run -it --rm rubylang/all-ruby env ALL_RUBY_SINCE=ruby-1.4 ./all-ruby -e '$KCODE="e"; p $KCODE'
ruby-1.4.0            "EUC"
...
ruby-1.8.7-p374       "EUC"
ruby-1.9.0-0          -e:1: warning: variable $KCODE is no longer effective; ignored
                      -e:1: warning: variable $KCODE is no longer effective
                      nil
...
ruby-2.7.1            -e:1: warning: variable $KCODE is no longer effective; ignored
                      -e:1: warning: variable $KCODE is no longer effective
                      nil
```



-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>