Issue #17101 has been reported by fitmap (Justin Peal).

----------------------------------------
Bug #17101: YAML.load_file: Massive slowdown under Ruby 2.7 vs. Ruby 2.4
https://bugs.ruby-lang.org/issues/17101

* Author: fitmap (Justin Peal)
* Status: Open
* Priority: Normal
* ruby -v: ruby 2.7.1p83 (2020-03-31 revision a0c7c23c9c) [x64-mingw32]
* Backport: 2.5: UNKNOWN, 2.6: UNKNOWN, 2.7: UNKNOWN
----------------------------------------
When use Ruby 2.4, the following program runs fast, After ungrade to Ruby 2.7, the same program runs very very slow. Please unzip the attach first for test.

require 'yaml'
YAML.load_file('qlnv_h_h.yaml')

---Files--------------------------------
qlnv_h_h.7z (1.41 MB)


-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>