Issue #17051 has been reported by thoen / classroomparent.com (Tom Hoen).

----------------------------------------
Bug #17051: Crash when attempting to load schema in Rails application
https://bugs.ruby-lang.org/issues/17051

* Author: thoen / classroomparent.com (Tom Hoen)
* Status: Open
* Priority: Normal
* ruby -v: 2.3.1, 2.3.8, 2.4.9
* Backport: 2.5: UNKNOWN, 2.6: UNKNOWN, 2.7: UNKNOWN
----------------------------------------
I am experiencing a crash when running `rake db:schema:load` or `rake db:migrate` in a Rails 4.2.9/Mysql2 0.4.0 application. 

I don't believe it is a specific issue with a ruby version, as I have tried with Rubies 2.3.1, 2.3.8, and 2.4.9. 

I also have another rails application (also Rails 4.2.9 and Mysql2 0.4.0 where I can successfully run those commands. 

Yesterday I had to reinstall RVM and all of my Rubies. That is when the issue began. Up until then, I have had no issues running that command in the same application. 

I have tried running the command after removing all of the gems in the application other than Rails and Mysql2. 

Reviewing the stack trace, I am not seeing anything particular to the application that might be culprit. 

I have also uninstalled and reinstalled Rails and Mysql2 gems. 

---Files--------------------------------
ruby_2020-07-25-142435_NFG-TOM-1602.crash (57.1 KB)


-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>