Issue #17040 has been updated by shyouhei (Shyouhei Urabe).


I'm pretty confident that nobody is against such change.  But opening an issue anyways, because this is a breaking change.

----------------------------------------
Feature #17040: cleanup include/ruby/backward*
https://bugs.ruby-lang.org/issues/17040#change-86639

* Author: shyouhei (Shyouhei Urabe)
* Status: Open
* Priority: Normal
----------------------------------------
I recently noticed [[ruby-dev:35813]](http://blade.nagaokaut.ac.jp/cgi-bin/scat.rb/ruby/ruby-dev/35813):

> こんなところでどうでしょうか。include/ruby/backwardは2.0までには
> 削除するということで。

It reads: "How about the following.  Will delete include/ruby/backward until 2.0."

In reality the directory lasted for the entire 2.x era.  But isn't 3.0 a good time to finally delete them?

- include/ruby/backward/2/extern.h: deprecated since 1.8.0. [PR](https://github.com/ruby/ruby/pull/3338)
- include/ruby/backward/classext.h: deprecated since 1.9.3. [PR](https://github.com/ruby/ruby/pull/3340)
    - struct RClassDeprecated: deprecated since 2.3.0. [PR](https://github.com/ruby/ruby/pull/3341)
- include/ruby/backward/rubysig.h: deprecated since 1.9.0. [PR](https://github.com/ruby/ruby/pull/3343)
- include/ruby/backward/rubyio.h: deprecated since 1.9.0. [PR](https://github.com/ruby/ruby/pull/3344)
- include/ruby/backward/st.h: deprecated since 1.9.0. [PR](https://github.com/ruby/ruby/pull/3345)
- include/ruby/backward/util.h: deprecated since 1.9.0. [PR](https://github.com/ruby/ruby/pull/3345)



-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>