Issue #17003 has been reported by deivid (David Rodr=EDguez).

----------------------------------------
Bug #17003: Segfault during bundler specs on Windows
https://bugs.ruby-lang.org/issues/17003

* Author: deivid (David Rodr=EDguez)
* Status: Open
* Priority: Normal
* Backport: 2.5: UNKNOWN, 2.6: UNKNOWN, 2.7: UNKNOWN
----------------------------------------
About a month ago, we got a segfault on Windows while running bundler specs=
 in CI.

I'm posting the log here in case there's something obvious in there that ne=
eds fixing.

```
Failures:

  1) [TEST_ENV_NUMBER=3D1] bundle add with --skip-install adds gem to Gemfi=
le but is not installed
     Failure/Error: expect(bundled_app_gemfile.read).to match(/gem "foo", "=
=3D 2.0"/)

       expected "source \"file:///d:/a/rubygems/rubygems/bundler/tmp/1/gems=
/remote2\"\ngem \"weakling\", \"~> 0.0.1\"\n" to match /gem "foo", "=3D 2.0=
"/
       Diff:
       @@ -1,2 +1,3 @@
       -/gem "foo", "=3D 2.0"/
       +source "file:///d:/a/rubygems/rubygems/bundler/tmp/1/gems/remote2"
       +gem "weakling", "~> 0.0.1"


       Commands:
       $ gem build rack
       Successfully built RubyGem
         Name: rack
         Version: 1.2
         File: rack-1.2.gem
       # $? =3D> 0

       $ gem build foo
       Successfully built RubyGem
         Name: foo
         Version: 1.1
         File: foo-1.1.gem
       # $? =3D> 0

       $ gem build foo
       Successfully built RubyGem
         Name: foo
         Version: 2.0
         File: foo-2.0.gem
       # $? =3D> 0

       $ gem build baz
       Successfully built RubyGem
         Name: baz
         Version: 1.2.3
         File: baz-1.2.3.gem
       # $? =3D> 0

       $ gem build bar
       Successfully built RubyGem
         Name: bar
         Version: 0.12.3
         File: bar-0.12.3.gem
       # $? =3D> 0

       $ gem build cat
       Successfully built RubyGem
         Name: cat
         Version: 0.12.3.pre
         File: cat-0.12.3.pre.gem
       # $? =3D> 0

       $ gem build dog
       Successfully built RubyGem
         Name: dog
         Version: 1.1.3.pre
         File: dog-1.1.3.pre.gem
       # $? =3D> 0

       $ gem generate_index
       Generating Marshal quick index gemspecs for 70 gems
       ....................................................................=
..
       Complete
       Generated Marshal quick index gemspecs: 0.038s
       Generating specs index
       Generated specs index: 0.001s
       Generating latest specs index
       Generated latest specs index: 0.001s
       Generating prerelease specs index
       Generated prerelease specs index: 0.000s
       Compressing indices
       Compressed indices: 0.002s
       # $? =3D> 0

       $ git init
       Initialized empty Git repository in D:/a/rubygems/rubygems/bundler/t=
mp/1/libs/foo-2.0/.git/
       # $? =3D> 0

       $ git add *
       # $? =3D> 0

       $ git config user.email lol / wut.com
       # $? =3D> 0

       $ git config user.name lolwut
       # $? =3D> 0

       $ git config commit.gpgsign false
       # $? =3D> 0

       $ git commit -m OMG_INITIAL_COMMIT
       [master (root-commit) 07ce25c] OMG_INITIAL_COMMIT
        3 files changed, 21 insertions(+)
        create mode 100644 foo.gemspec
        create mode 100644 lib/foo.rb
        create mode 100644 lib/foo/source.rb
       # $? =3D> 0

       $ D:/rubyinstaller-2.7.1-1-x64/bin/ruby.exe -Id:/a/rubygems/rubygems=
/bundler/spec -rd:/a/rubygems/rubygems/bundler/spec/support/artifice/fail.r=
b -rd:/a/rubygems/rubygems/bundler/spec/support/hax.rb d:/a/rubygems/rubyge=
ms/bundler/tmp/1/gems/system/bin/bundle install --retry 0
       Fetching source index from file:///d:/a/rubygems/rubygems/bundler/tm=
p/1/gems/remote2/
       Resolving dependencies...
       Using bundler 2.2.0.dev
       Fetching weakling 0.0.3
       Installing weakling 0.0.3
       Bundle complete! 1 Gemfile dependency, 2 gems now installed.
       Use `bundle info [gemname]` to see where a bundled gem is installed.
       # $? =3D> 0

       $ D:/rubyinstaller-2.7.1-1-x64/bin/ruby.exe -Id:/a/rubygems/rubygems=
/bundler/spec -rd:/a/rubygems/rubygems/bundler/spec/support/artifice/fail.r=
b -rd:/a/rubygems/rubygems/bundler/spec/support/hax.rb d:/a/rubygems/rubyge=
ms/bundler/tmp/1/gems/system/bin/bundle add foo --skip-install --version=3D=
2.0
       d:/a/rubygems/rubygems/lib/rubygems/core_ext/kernel_require.rb:83: [=
BUG] try to mark T_NONE object
       ruby 2.7.1p83 (2020-03-31 revision a0c7c23c9c) [x64-mingw32]

       -- Control frame information ---------------------------------------=
--------
       c:0050 p:---- s:0324 e:000323 CFUNC  :require
       c:0049 p:0195 s:0319 e:000318 METHOD d:/a/rubygems/rubygems/lib/ruby=
gems/core_ext/kernel_require.rb:83
       c:0048 p:0005 s:0302 e:000301 TOP    d:/a/rubygems/rubygems/lib/ruby=
gems/uri_parsing.rb:3 [FINISH]
       c:0047 p:---- s:0299 e:000298 CFUNC  :require
       c:0046 p:0195 s:0294 e:000293 METHOD d:/a/rubygems/rubygems/lib/ruby=
gems/core_ext/kernel_require.rb:83
       c:0045 p:0035 s:0277 e:000276 TOP    d:/a/rubygems/rubygems/lib/ruby=
gems/remote_fetcher.rb:7 [FINISH]
       c:0044 p:---- s:0274 e:000273 CFUNC  :require
       c:0043 p:0195 s:0269 e:000268 METHOD d:/a/rubygems/rubygems/lib/ruby=
gems/core_ext/kernel_require.rb:83
       c:0042 p:0011 s:0252 e:000251 TOP    d:/a/rubygems/rubygems/bundler/=
tmp/1/gems/system/gems/bundler-2.2.0.dev/lib/bundler/fetcher/index.rb:4 [FI=
NISH]
       c:0041 p:---- s:0249 e:000248 CFUNC  :require
       c:0040 p:0195 s:0244 e:000243 METHOD d:/a/rubygems/rubygems/lib/ruby=
gems/core_ext/kernel_require.rb:83 [FINISH]
       c:0039 p:0453 s:0227 e:000222 CLASS  d:/a/rubygems/rubygems/bundler/=
tmp/1/gems/system/gems/bundler-2.2.0.dev/lib/bundler/fetcher.rb:221
       c:0038 p:0007 s:0219 e:000218 CLASS  d:/a/rubygems/rubygems/bundler/=
tmp/1/gems/system/gems/bundler-2.2.0.dev/lib/bundler/fetcher.rb:11
       c:0037 p:0037 s:0216 e:000215 TOP    d:/a/rubygems/rubygems/bundler/=
tmp/1/gems/system/gems/bundler-2.2.0.dev/lib/bundler/fetcher.rb:9 [FINISH]
       c:0036 p:---- s:0213 e:000212 CFUNC  :require
       c:0035 p:0195 s:0208 e:000207 METHOD d:/a/rubygems/rubygems/lib/ruby=
gems/core_ext/kernel_require.rb:83 [FINISH]
       c:0034 p:0035 s:0191 e:000188 BLOCK  d:/a/rubygems/rubygems/bundler/=
tmp/1/gems/system/gems/bundler-2.2.0.dev/lib/bundler/source/rubygems.rb:255=
 [FINISH]
       c:0033 p:---- s:0184 e:000183 CFUNC  :map
       c:0032 p:0020 s:0180 e:000179 METHOD d:/a/rubygems/rubygems/bundler/=
tmp/1/gems/system/gems/bundler-2.2.0.dev/lib/bundler/source/rubygems.rb:253
       c:0031 p:0004 s:0176 e:000175 BLOCK  d:/a/rubygems/rubygems/bundler/=
tmp/1/gems/system/gems/bundler-2.2.0.dev/lib/bundler/source/rubygems.rb:390
       c:0030 p:0009 s:0170 e:000169 METHOD d:/a/rubygems/rubygems/bundler/=
tmp/1/gems/system/gems/bundler-2.2.0.dev/lib/bundler/index.rb:11
       c:0029 p:0026 s:0165 e:000164 METHOD d:/a/rubygems/rubygems/bundler/=
tmp/1/gems/system/gems/bundler-2.2.0.dev/lib/bundler/source/rubygems.rb:389
       c:0028 p:0022 s:0161 e:000160 METHOD d:/a/rubygems/rubygems/bundler/=
tmp/1/gems/system/gems/bundler-2.2.0.dev/lib/bundler/source/rubygems.rb:88
       c:0027 p:0021 s:0156 e:000154 BLOCK  d:/a/rubygems/rubygems/bundler/=
tmp/1/gems/system/gems/bundler-2.2.0.dev/lib/bundler/definition.rb:279 [FIN=
ISH]
       c:0026 p:---- s:0151 e:000150 CFUNC  :each
       c:0025 p:0019 s:0147 e:000146 BLOCK  d:/a/rubygems/rubygems/bundler/=
tmp/1/gems/system/gems/bundler-2.2.0.dev/lib/bundler/definition.rb:277
       c:0024 p:0009 s:0142 e:000141 METHOD d:/a/rubygems/rubygems/bundler/=
tmp/1/gems/system/gems/bundler-2.2.0.dev/lib/bundler/index.rb:11
       c:0023 p:0026 s:0137 e:000136 METHOD d:/a/rubygems/rubygems/bundler/=
tmp/1/gems/system/gems/bundler-2.2.0.dev/lib/bundler/definition.rb:274
       c:0022 p:0133 s:0133 e:000129 METHOD d:/a/rubygems/rubygems/bundler/=
tmp/1/gems/system/gems/bundler-2.2.0.dev/lib/bundler/definition.rb:264
       c:0021 p:0017 s:0124 e:000123 METHOD d:/a/rubygems/rubygems/bundler/=
tmp/1/gems/system/gems/bundler-2.2.0.dev/lib/bundler/definition.rb:175
       c:0020 p:0025 s:0114 e:000113 METHOD d:/a/rubygems/rubygems/bundler/=
tmp/1/gems/system/gems/bundler-2.2.0.dev/lib/bundler/definition.rb:163
       c:0019 p:0075 s:0110 e:000109 BLOCK  d:/a/rubygems/rubygems/bundler/=
tmp/1/gems/system/gems/bundler-2.2.0.dev/lib/bundler/injector.rb:47
       c:0018 p:0035 s:0106 e:000105 METHOD d:/a/rubygems/rubygems/bundler/=
tmp/1/gems/system/gems/bundler-2.2.0.dev/lib/bundler/settings.rb:121
       c:0017 p:0047 s:0100 e:000099 METHOD d:/a/rubygems/rubygems/bundler/=
tmp/1/gems/system/gems/bundler-2.2.0.dev/lib/bundler/injector.rb:32
       c:0016 p:0039 s:0094 e:000093 METHOD d:/a/rubygems/rubygems/bundler/=
tmp/1/gems/system/gems/bundler-2.2.0.dev/lib/bundler/injector.rb:9
       c:0015 p:0045 s:0087 e:000086 METHOD d:/a/rubygems/rubygems/bundler/=
tmp/1/gems/system/gems/bundler-2.2.0.dev/lib/bundler/cli/add.rb:30
       c:0014 p:0007 s:0082 e:000081 METHOD d:/a/rubygems/rubygems/bundler/=
tmp/1/gems/system/gems/bundler-2.2.0.dev/lib/bundler/cli/add.rb:16
       c:0013 p:0026 s:0078 e:000077 METHOD d:/a/rubygems/rubygems/bundler/=
tmp/1/gems/system/gems/bundler-2.2.0.dev/lib/bundler/cli.rb:403
       c:0012 p:0054 s:0073 e:000072 METHOD d:/a/rubygems/rubygems/bundler/=
tmp/1/gems/system/gems/bundler-2.2.0.dev/lib/bundler/vendor/thor/lib/thor/c=
ommand.rb:27
       c:0011 p:0040 s:0065 e:000064 METHOD d:/a/rubygems/rubygems/bundler/=
tmp/1/gems/system/gems/bundler-2.2.0.dev/lib/bundler/vendor/thor/lib/thor/i=
nvocation.rb:127
       c:0010 p:0239 s:0058 e:000057 METHOD d:/a/rubygems/rubygems/bundler/=
tmp/1/gems/system/gems/bundler-2.2.0.dev/lib/bundler/vendor/thor/lib/thor.r=
b:399
       c:0009 p:0008 s:0045 e:000044 METHOD d:/a/rubygems/rubygems/bundler/=
tmp/1/gems/system/gems/bundler-2.2.0.dev/lib/bundler/cli.rb:30
       c:0008 p:0066 s:0040 e:000039 METHOD d:/a/rubygems/rubygems/bundler/=
tmp/1/gems/system/gems/bundler-2.2.0.dev/lib/bundler/vendor/thor/lib/thor/b=
ase.rb:476
       c:0007 p:0008 s:0033 e:000032 METHOD d:/a/rubygems/rubygems/bundler/=
tmp/1/gems/system/gems/bundler-2.2.0.dev/lib/bundler/cli.rb:24
       c:0006 p:0109 s:0028 e:000027 BLOCK  d:/a/rubygems/rubygems/bundler/=
tmp/1/gems/system/gems/bundler-2.2.0.dev/exe/bundle:49
       c:0005 p:0002 s:0022 e:000021 METHOD d:/a/rubygems/rubygems/bundler/=
tmp/1/gems/system/gems/bundler-2.2.0.dev/lib/bundler/friendly_errors.rb:117
       c:0004 p:0162 s:0017 E:0016d8 TOP    d:/a/rubygems/rubygems/bundler/=
tmp/1/gems/system/gems/bundler-2.2.0.dev/exe/bundle:37 [FINISH]
       c:0003 p:---- s:0013 e:000012 CFUNC  :load
       c:0002 p:0112 s:0008 E:0017c0 EVAL   d:/a/rubygems/rubygems/bundler/=
tmp/1/gems/system/bin/bundle:23 [FINISH]
       c:0001 p:0000 s:0003 E:000d20 (none) [FINISH]

       -- Ruby level backtrace information --------------------------------=
--------
       d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/bin/bundle:23:in `<=
main>'
       d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/bin/bundle:23:in `l=
oad'
       d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-2.2.0.=
dev/exe/bundle:37:in `<top (required)>'
       d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-2.2.0.=
dev/lib/bundler/friendly_errors.rb:117:in `with_friendly_errors'
       d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-2.2.0.=
dev/exe/bundle:49:in `block in <top (required)>'
       d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-2.2.0.=
dev/lib/bundler/cli.rb:24:in `start'
       d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-2.2.0.=
dev/lib/bundler/vendor/thor/lib/thor/base.rb:476:in `start'
       d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-2.2.0.=
dev/lib/bundler/cli.rb:30:in `dispatch'
       d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-2.2.0.=
dev/lib/bundler/vendor/thor/lib/thor.rb:399:in `dispatch'
       d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-2.2.0.=
dev/lib/bundler/vendor/thor/lib/thor/invocation.rb:127:in `invoke_command'
       d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-2.2.0.=
dev/lib/bundler/vendor/thor/lib/thor/command.rb:27:in `run'
       d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-2.2.0.=
dev/lib/bundler/cli.rb:403:in `add'
       d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-2.2.0.=
dev/lib/bundler/cli/add.rb:16:in `run'
       d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-2.2.0.=
dev/lib/bundler/cli/add.rb:30:in `inject_dependencies'
       d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-2.2.0.=
dev/lib/bundler/injector.rb:9:in `inject'
       d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-2.2.0.=
dev/lib/bundler/injector.rb:32:in `inject'
       d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-2.2.0.=
dev/lib/bundler/settings.rb:121:in `temporary'
       d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-2.2.0.=
dev/lib/bundler/injector.rb:47:in `block in inject'
       d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-2.2.0.=
dev/lib/bundler/definition.rb:163:in `resolve_remotely!'
       d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-2.2.0.=
dev/lib/bundler/definition.rb:175:in `specs'
       d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-2.2.0.=
dev/lib/bundler/definition.rb:264:in `resolve'
       d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-2.2.0.=
dev/lib/bundler/definition.rb:274:in `index'
       d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-2.2.0.=
dev/lib/bundler/index.rb:11:in `build'
       d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-2.2.0.=
dev/lib/bundler/definition.rb:277:in `block in index'
       d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-2.2.0.=
dev/lib/bundler/definition.rb:277:in `each'
       d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-2.2.0.=
dev/lib/bundler/definition.rb:279:in `block (2 levels) in index'
       d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-2.2.0.=
dev/lib/bundler/source/rubygems.rb:88:in `specs'
       d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-2.2.0.=
dev/lib/bundler/source/rubygems.rb:389:in `remote_specs'
       d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-2.2.0.=
dev/lib/bundler/index.rb:11:in `build'
       d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-2.2.0.=
dev/lib/bundler/source/rubygems.rb:390:in `block in remote_specs'
       d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-2.2.0.=
dev/lib/bundler/source/rubygems.rb:253:in `fetchers'
       d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-2.2.0.=
dev/lib/bundler/source/rubygems.rb:253:in `map'
       d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-2.2.0.=
dev/lib/bundler/source/rubygems.rb:255:in `block in fetchers'
       d:/a/rubygems/rubygems/lib/rubygems/core_ext/kernel_require.rb:83:in=
 `require'
       d:/a/rubygems/rubygems/lib/rubygems/core_ext/kernel_require.rb:83:in=
 `require'
       d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-2.2.0.=
dev/lib/bundler/fetcher.rb:9:in `<top (required)>'
       d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-2.2.0.=
dev/lib/bundler/fetcher.rb:11:in `<module:Bundler>'
       d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-2.2.0.=
dev/lib/bundler/fetcher.rb:221:in `<class:Fetcher>'
       d:/a/rubygems/rubygems/lib/rubygems/core_ext/kernel_require.rb:83:in=
 `require'
       d:/a/rubygems/rubygems/lib/rubygems/core_ext/kernel_require.rb:83:in=
 `require'
       d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-2.2.0.=
dev/lib/bundler/fetcher/index.rb:4:in `<top (required)>'
       d:/a/rubygems/rubygems/lib/rubygems/core_ext/kernel_require.rb:83:in=
 `require'
       d:/a/rubygems/rubygems/lib/rubygems/core_ext/kernel_require.rb:83:in=
 `require'
       d:/a/rubygems/rubygems/lib/rubygems/remote_fetcher.rb:7:in `<top (re=
quired)>'
       d:/a/rubygems/rubygems/lib/rubygems/core_ext/kernel_require.rb:83:in=
 `require'
       d:/a/rubygems/rubygems/lib/rubygems/core_ext/kernel_require.rb:83:in=
 `require'
       d:/a/rubygems/rubygems/lib/rubygems/uri_parsing.rb:3:in `<top (requi=
red)>'
       d:/a/rubygems/rubygems/lib/rubygems/core_ext/kernel_require.rb:83:in=
 `require'
       d:/a/rubygems/rubygems/lib/rubygems/core_ext/kernel_require.rb:83:in=
 `require'

       -- C level backtrace information -----------------------------------=
--------
       C:\windows\SYSTEM32\ntdll.dll(NtWaitForSingleObject+0x14) [0x00007ff=
b2161f7e4]
       C:\windows\System32\KERNELBASE.dll(WaitForSingleObjectEx+0x93) [0x00=
007ffb1d6789b3]
       D:\rubyinstaller-2.7.1-1-x64\bin\x64-msvcrt-ruby270.dll(rb_vm_bugrep=
ort+0x37b) [0x00000000653c96ab]
       D:\rubyinstaller-2.7.1-1-x64\bin\x64-msvcrt-ruby270.dll(rb_bug+0x7c)=
 [0x00000000653f55eb]
       D:\rubyinstaller-2.7.1-1-x64\bin\x64-msvcrt-ruby270.dll(rb_memerror+=
0x1f7) [0x00000000653f5bfa]
       D:\rubyinstaller-2.7.1-1-x64\bin\x64-msvcrt-ruby270.dll(rb_vm_mark+0=
xdc) [0x00000000653c370c]
       D:\rubyinstaller-2.7.1-1-x64\bin\x64-msvcrt-ruby270.dll(rb_gc_mark+0=
x295) [0x0000000065208865]
       D:\rubyinstaller-2.7.1-1-x64\bin\x64-msvcrt-ruby270.dll(rb_objspace_=
each_objects+0x7c5) [0x000000006520a005]
       D:\rubyinstaller-2.7.1-1-x64\bin\x64-msvcrt-ruby270.dll(rb_data_obje=
ct_wrap+0x2bd) [0x000000006520c49d]
       D:\rubyinstaller-2.7.1-1-x64\bin\x64-msvcrt-ruby270.dll(rb_wb_protec=
ted_newobj_of+0x79) [0x000000006520c969]
       D:\rubyinstaller-2.7.1-1-x64\bin\x64-msvcrt-ruby270.dll(rb_str_new+0=
x2b) [0x000000006533c4cb]
       D:\rubyinstaller-2.7.1-1-x64\bin\x64-msvcrt-ruby270.dll(rb_io_ungetb=
yte+0x1135) [0x00000000652326a5]
       D:\rubyinstaller-2.7.1-1-x64\bin\x64-msvcrt-ruby270.dll(rb_uv_to_utf=
8+0x27be) [0x000000006529eafe]
       D:\rubyinstaller-2.7.1-1-x64\bin\x64-msvcrt-ruby270.dll(ruby_yyparse=
+0x13014) [0x00000000652c2224]
       D:\rubyinstaller-2.7.1-1-x64\bin\x64-msvcrt-ruby270.dll(ruby_yyparse=
+0x1a956) [0x00000000652c9b66]
       D:\rubyinstaller-2.7.1-1-x64\bin\x64-msvcrt-ruby270.dll(rb_suppress_=
tracing+0x134) [0x00000000653cd6b4]
       D:\rubyinstaller-2.7.1-1-x64\bin\x64-msvcrt-ruby270.dll(rb_parser_co=
mpile_file_path+0xa8) [0x00000000652a7078]
       D:\rubyinstaller-2.7.1-1-x64\bin\x64-msvcrt-ruby270.dll(onig_set_met=
a_char+0x2c77) [0x000000006531ee67]
       D:\rubyinstaller-2.7.1-1-x64\bin\x64-msvcrt-ruby270.dll(rb_ensure+0x=
142) [0x00000000651ee992]
       D:\rubyinstaller-2.7.1-1-x64\bin\x64-msvcrt-ruby270.dll(rb_parser_lo=
ad_file+0xfc) [0x000000006531faec]
       D:\rubyinstaller-2.7.1-1-x64\bin\x64-msvcrt-ruby270.dll(rb_get_expan=
ded_load_path+0x1458) [0x00000000652502b8]
       D:\rubyinstaller-2.7.1-1-x64\bin\x64-msvcrt-ruby270.dll(rb_f_require=
+0x22) [0x0000000065250412]
       D:\rubyinstaller-2.7.1-1-x64\bin\x64-msvcrt-ruby270.dll(rb_error_ari=
ty+0x338) [0x00000000653a1bb8]
       D:\rubyinstaller-2.7.1-1-x64\bin\x64-msvcrt-ruby270.dll(rb_check_fun=
call_default+0x8f6) [0x00000000653ba126]
       D:\rubyinstaller-2.7.1-1-x64\bin\x64-msvcrt-ruby270.dll(rb_vm_exec+0=
x23c) [0x00000000653abf2c]
       D:\rubyinstaller-2.7.1-1-x64\bin\x64-msvcrt-ruby270.dll(rb_get_expan=
ded_load_path+0x13f1) [0x0000000065250251]
       D:\rubyinstaller-2.7.1-1-x64\bin\x64-msvcrt-ruby270.dll(rb_f_require=
+0x22) [0x0000000065250412]
       D:\rubyinstaller-2.7.1-1-x64\bin\x64-msvcrt-ruby270.dll(rb_error_ari=
ty+0x338) [0x00000000653a1bb8]
       D:\rubyinstaller-2.7.1-1-x64\bin\x64-msvcrt-ruby270.dll(rb_check_fun=
call_default+0x8f6) [0x00000000653ba126]
       D:\rubyinstaller-2.7.1-1-x64\bin\x64-msvcrt-ruby270.dll(rb_vm_exec+0=
x23c) [0x00000000653abf2c]
       D:\rubyinstaller-2.7.1-1-x64\bin\x64-msvcrt-ruby270.dll(rb_get_expan=
ded_load_path+0x13f1) [0x0000000065250251]
       D:\rubyinstaller-2.7.1-1-x64\bin\x64-msvcrt-ruby270.dll(rb_f_require=
+0x22) [0x0000000065250412]
       D:\rubyinstaller-2.7.1-1-x64\bin\x64-msvcrt-ruby270.dll(rb_error_ari=
ty+0x338) [0x00000000653a1bb8]
       D:\rubyinstaller-2.7.1-1-x64\bin\x64-msvcrt-ruby270.dll(rb_check_fun=
call_default+0x8f6) [0x00000000653ba126]
       D:\rubyinstaller-2.7.1-1-x64\bin\x64-msvcrt-ruby270.dll(rb_vm_exec+0=
x23c) [0x00000000653abf2c]
       D:\rubyinstaller-2.7.1-1-x64\bin\x64-msvcrt-ruby270.dll(rb_get_expan=
ded_load_path+0x13f1) [0x0000000065250251]
       D:\rubyinstaller-2.7.1-1-x64\bin\x64-msvcrt-ruby270.dll(rb_f_require=
+0x22) [0x0000000065250412]
       D:\rubyinstaller-2.7.1-1-x64\bin\x64-msvcrt-ruby270.dll(rb_error_ari=
ty+0x338) [0x00000000653a1bb8]
       D:\rubyinstaller-2.7.1-1-x64\bin\x64-msvcrt-ruby270.dll(rb_check_fun=
call_default+0x8f6) [0x00000000653ba126]
       D:\rubyinstaller-2.7.1-1-x64\bin\x64-msvcrt-ruby270.dll(rb_vm_exec+0=
x23c) [0x00000000653abf2c]
       D:\rubyinstaller-2.7.1-1-x64\bin\x64-msvcrt-ruby270.dll(rb_vm_invoke=
_proc+0x9a2) [0x00000000653b18d2]
       D:\rubyinstaller-2.7.1-1-x64\bin\x64-msvcrt-ruby270.dll(rb_funcallv_=
with_cc+0x111) [0x00000000653b55f1]
       D:\rubyinstaller-2.7.1-1-x64\bin\x64-msvcrt-ruby270.dll(rb_gvar_read=
only_setter+0x1f9) [0x0000000065391539]
       D:\rubyinstaller-2.7.1-1-x64\bin\x64-msvcrt-ruby270.dll(rb_ensure+0x=
142) [0x00000000651ee992]
       D:\rubyinstaller-2.7.1-1-x64\bin\x64-msvcrt-ruby270.dll(rb_autoload_=
load+0x1d7) [0x00000000653972e7]
       D:\rubyinstaller-2.7.1-1-x64\bin\x64-msvcrt-ruby270.dll(rb_check_fun=
call_default+0x51b9) [0x00000000653be9e9]
       D:\rubyinstaller-2.7.1-1-x64\bin\x64-msvcrt-ruby270.dll(rb_vm_exec+0=
x23c) [0x00000000653abf2c]
       D:\rubyinstaller-2.7.1-1-x64\bin\x64-msvcrt-ruby270.dll(rb_get_expan=
ded_load_path+0x13f1) [0x0000000065250251]
       D:\rubyinstaller-2.7.1-1-x64\bin\x64-msvcrt-ruby270.dll(rb_f_require=
+0x22) [0x0000000065250412]
       D:\rubyinstaller-2.7.1-1-x64\bin\x64-msvcrt-ruby270.dll(rb_error_ari=
ty+0x338) [0x00000000653a1bb8]
       D:\rubyinstaller-2.7.1-1-x64\bin\x64-msvcrt-ruby270.dll(rb_check_fun=
call_default+0x8f6) [0x00000000653ba126]
       D:\rubyinstaller-2.7.1-1-x64\bin\x64-msvcrt-ruby270.dll(rb_vm_exec+0=
x23c) [0x00000000653abf2c]
       D:\rubyinstaller-2.7.1-1-x64\bin\x64-msvcrt-ruby270.dll(rb_vm_invoke=
_proc+0x9a2) [0x00000000653b18d2]
       D:\rubyinstaller-2.7.1-1-x64\bin\x64-msvcrt-ruby270.dll(rb_funcallv_=
with_cc+0x111) [0x00000000653b55f1]
       D:\rubyinstaller-2.7.1-1-x64\bin\x64-msvcrt-ruby270.dll(rb_gvar_read=
only_setter+0x1f9) [0x0000000065391539]
       D:\rubyinstaller-2.7.1-1-x64\bin\x64-msvcrt-ruby270.dll(rb_ensure+0x=
142) [0x00000000651ee992]
       D:\rubyinstaller-2.7.1-1-x64\bin\x64-msvcrt-ruby270.dll(rb_autoload_=
load+0x1d7) [0x00000000653972e7]
       D:\rubyinstaller-2.7.1-1-x64\bin\x64-msvcrt-ruby270.dll(rb_public_co=
nst_get_from+0x223) [0x00000000653985d3]
       D:\rubyinstaller-2.7.1-1-x64\bin\x64-msvcrt-ruby270.dll(rb_check_fun=
call_default+0x4366) [0x00000000653bdb96]
       D:\rubyinstaller-2.7.1-1-x64\bin\x64-msvcrt-ruby270.dll(rb_vm_exec+0=
x23c) [0x00000000653abf2c]
       D:\rubyinstaller-2.7.1-1-x64\bin\x64-msvcrt-ruby270.dll(rb_yield+0x3=
07) [0x00000000653b03b7]
       D:\rubyinstaller-2.7.1-1-x64\bin\x64-msvcrt-ruby270.dll(rb_ary_sort+=
0xa1f) [0x000000006514bfbf]
       D:\rubyinstaller-2.7.1-1-x64\bin\x64-msvcrt-ruby270.dll(rb_error_ari=
ty+0x338) [0x00000000653a1bb8]
       D:\rubyinstaller-2.7.1-1-x64\bin\x64-msvcrt-ruby270.dll(rb_vm_invoke=
_bmethod+0x131b) [0x00000000653adb0b]
       D:\rubyinstaller-2.7.1-1-x64\bin\x64-msvcrt-ruby270.dll(rb_check_fun=
call_default+0x9ee) [0x00000000653ba21e]
       D:\rubyinstaller-2.7.1-1-x64\bin\x64-msvcrt-ruby270.dll(rb_vm_exec+0=
x23c) [0x00000000653abf2c]
       D:\rubyinstaller-2.7.1-1-x64\bin\x64-msvcrt-ruby270.dll(rb_yield+0x3=
07) [0x00000000653b03b7]
       D:\rubyinstaller-2.7.1-1-x64\bin\x64-msvcrt-ruby270.dll(rb_ary_each+=
0x3d) [0x0000000065145afd]
       D:\rubyinstaller-2.7.1-1-x64\bin\x64-msvcrt-ruby270.dll(rb_error_ari=
ty+0x338) [0x00000000653a1bb8]
       D:\rubyinstaller-2.7.1-1-x64\bin\x64-msvcrt-ruby270.dll(rb_vm_invoke=
_bmethod+0x131b) [0x00000000653adb0b]
       D:\rubyinstaller-2.7.1-1-x64\bin\x64-msvcrt-ruby270.dll(rb_check_fun=
call_default+0x9ee) [0x00000000653ba21e]
       D:\rubyinstaller-2.7.1-1-x64\bin\x64-msvcrt-ruby270.dll(rb_vm_exec+0=
x9e5) [0x00000000653ac6d5]
       D:\rubyinstaller-2.7.1-1-x64\bin\x64-msvcrt-ruby270.dll(rb_resolve_f=
eature_path+0x80a) [0x000000006524ecda]
       D:\rubyinstaller-2.7.1-1-x64\bin\x64-msvcrt-ruby270.dll(rb_error_ari=
ty+0x338) [0x00000000653a1bb8]
       D:\rubyinstaller-2.7.1-1-x64\bin\x64-msvcrt-ruby270.dll(rb_vm_invoke=
_bmethod+0x131b) [0x00000000653adb0b]
       D:\rubyinstaller-2.7.1-1-x64\bin\x64-msvcrt-ruby270.dll(rb_check_fun=
call_default+0x8f6) [0x00000000653ba126]
       D:\rubyinstaller-2.7.1-1-x64\bin\x64-msvcrt-ruby270.dll(rb_vm_exec+0=
x9e5) [0x00000000653ac6d5]
       D:\rubyinstaller-2.7.1-1-x64\bin\x64-msvcrt-ruby270.dll(rb_call_end_=
proc+0x152) [0x00000000651e88f2]
       D:\rubyinstaller-2.7.1-1-x64\bin\x64-msvcrt-ruby270.dll(ruby_run_nod=
e+0x95) [0x00000000651ed815]
        [0x0000000000402d49]
        [0x00000000004013b4]
        [0x000000000040150b]
       C:\windows\System32\KERNEL32.DLL(BaseThreadInitThunk+0x14) [0x00007f=
fb214a7974]

       -- Other runtime information ---------------------------------------=
--------

       * Loaded script: d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/bi=
n/bundle

       * Loaded features:

           0 enumerator.so
           1 thread.rb
           2 rational.so
           3 complex.so
           4 ruby2_keywords.rb
           5 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/x64-mingw32/enc/en=
cdb.so
           6 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/x64-mingw32/enc/tr=
ans/transdb.so
           7 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/x64-mingw32/enc/wi=
ndows_1252.so
           8 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/x64-mingw32/rbconf=
ig.rb
           9 d:/a/rubygems/rubygems/lib/rubygems/compatibility.rb
          10 d:/a/rubygems/rubygems/lib/rubygems/defaults.rb
          11 d:/a/rubygems/rubygems/lib/rubygems/deprecate.rb
          12 d:/a/rubygems/rubygems/lib/rubygems/errors.rb
          13 d:/a/rubygems/rubygems/lib/rubygems/version.rb
          14 d:/a/rubygems/rubygems/lib/rubygems/requirement.rb
          15 d:/a/rubygems/rubygems/lib/rubygems/platform.rb
          16 d:/a/rubygems/rubygems/lib/rubygems/basic_specification.rb
          17 d:/a/rubygems/rubygems/lib/rubygems/stub_specification.rb
          18 d:/a/rubygems/rubygems/lib/rubygems/util.rb
          19 d:/a/rubygems/rubygems/lib/rubygems/text.rb
          20 d:/a/rubygems/rubygems/lib/rubygems/user_interaction.rb
          21 d:/a/rubygems/rubygems/lib/rubygems/specification_policy.rb
          22 d:/a/rubygems/rubygems/lib/rubygems/util/list.rb
          23 d:/a/rubygems/rubygems/lib/rubygems/specification.rb
          24 d:/a/rubygems/rubygems/lib/rubygems/exceptions.rb
          25 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/site_ruby/2.7.0/ruby_ins=
taller/runtime/singleton.rb
          26 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/site_ruby/2.7.0/ruby_ins=
taller/runtime.rb
          27 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/site_ruby/2.7.0/ruby_ins=
taller/runtime/msys2_installation.rb
          28 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/x64-mingw32/fiddle=
.so
          29 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/fiddle/function.rb
          30 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/fiddle/closure.rb
          31 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/fiddle.rb
          32 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/site_ruby/2.7.0/ruby_ins=
taller/runtime/dll_directory.rb
          33 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/x64-mingw32/enc/ut=
f_16le.so
          34 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/x64-mingw32/enc/tr=
ans/utf_16_32.so
          35 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/rubygems/defaults/=
operating_system.rb
          36 d:/a/rubygems/rubygems/lib/rubygems/bundler_version_finder.rb
          37 d:/a/rubygems/rubygems/lib/rubygems/dependency.rb
          38 d:/a/rubygems/rubygems/lib/rubygems/core_ext/kernel_gem.rb
          39 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/x64-mingw32/monito=
r.so
          40 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/monitor.rb
          41 d:/a/rubygems/rubygems/lib/rubygems/core_ext/kernel_require.rb
          42 d:/a/rubygems/rubygems/lib/rubygems/core_ext/kernel_warn.rb
          43 d:/a/rubygems/rubygems/lib/rubygems.rb
          44 d:/a/rubygems/rubygems/lib/rubygems/path_support.rb
          45 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/did_you_mean/versi=
on.rb
          46 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/did_you_mean/core_=
ext/name_error.rb
          47 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/did_you_mean/leven=
shtein.rb
          48 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/did_you_mean/jaro_=
winkler.rb
          49 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/did_you_mean/spell=
_checker.rb
          50 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/did_you_mean/spell=
_checkers/name_error_checkers/class_name_checker.rb
          51 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/did_you_mean/spell=
_checkers/name_error_checkers/variable_name_checker.rb
          52 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/did_you_mean/spell=
_checkers/name_error_checkers.rb
          53 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/did_you_mean/spell=
_checkers/method_name_checker.rb
          54 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/did_you_mean/spell=
_checkers/key_error_checker.rb
          55 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/did_you_mean/spell=
_checkers/null_checker.rb
          56 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/did_you_mean/forma=
tters/plain_formatter.rb
          57 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/did_you_mean/tree_=
spell_checker.rb
          58 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/did_you_mean.rb
          59 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/x64-mingw32/socket=
.so
          60 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/x64-mingw32/io/wai=
t.so
          61 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/socket.rb
          62 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/timeout.rb
          63 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/net/protocol.rb
          64 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/uri/version.rb
          65 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/uri/rfc2396_parser=
.rb
          66 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/uri/rfc3986_parser=
.rb
          67 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/uri/common.rb
          68 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/uri/generic.rb
          69 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/uri/file.rb
          70 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/uri/ftp.rb
          71 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/uri/http.rb
          72 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/uri/https.rb
          73 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/uri/ldap.rb
          74 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/uri/ldaps.rb
          75 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/uri/mailto.rb
          76 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/uri.rb
          77 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/x64-mingw32/zlib.so
          78 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/x64-mingw32/string=
io.so
          79 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/net/http/exception=
s.rb
          80 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/net/http/header.rb
          81 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/x64-mingw32/enc/wi=
ndows_31j.so
          82 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/net/http/generic_r=
equest.rb
          83 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/net/http/request.rb
          84 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/net/http/requests.=
rb
          85 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/net/http/response.=
rb
          86 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/net/http/responses=
.rb
          87 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/net/http/proxy_del=
ta.rb
          88 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/net/http/backward.=
rb
          89 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/net/http.rb
          90 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/x64-mingw32/digest=
.so
          91 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/digest.rb
          92 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/x64-mingw32/openss=
l.so
          93 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/openssl/bn.rb
          94 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/openssl/pkey.rb
          95 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/openssl/cipher.rb
          96 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/openssl/config.rb
          97 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/openssl/digest.rb
          98 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/openssl/x509.rb
          99 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/openssl/buffering.=
rb
         100 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/x64-mingw32/io/non=
block.so
         101 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/ipaddr.rb
         102 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/openssl/ssl.rb
         103 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/openssl/pkcs5.rb
         104 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/openssl.rb
         105 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/net/https.rb
         106 d:/a/rubygems/rubygems/bundler/spec/support/artifice/fail.rb
         107 d:/a/rubygems/rubygems/bundler/spec/support/hax.rb
         108 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/x64-mingw32/pathna=
me.so
         109 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/pathname.rb
         110 d:/a/rubygems/rubygems/bundler/spec/support/command_execution.=
rb
         111 d:/a/rubygems/rubygems/bundler/spec/support/path.rb
         112 d:/a/rubygems/rubygems/bundler/spec/support/the_bundle.rb
         113 d:/a/rubygems/rubygems/bundler/spec/support/helpers.rb
         114 d:/a/rubygems/rubygems/bundler/spec/support/rubygems_version_m=
anager.rb
         115 d:/a/rubygems/rubygems/bundler/spec/support/switch_rubygems.rb
         116 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/tsort.rb
         117 d:/a/rubygems/rubygems/lib/rubygems/request_set/gem_dependency=
_api.rb
         118 d:/a/rubygems/rubygems/lib/rubygems/request_set/lockfile/parse=
r.rb
         119 d:/a/rubygems/rubygems/lib/rubygems/request_set/lockfile/token=
izer.rb
         120 d:/a/rubygems/rubygems/lib/rubygems/request_set/lockfile.rb
         121 d:/a/rubygems/rubygems/lib/rubygems/request_set.rb
         122 d:/a/rubygems/rubygems/lib/rubygems/resolver/molinillo/lib/mol=
inillo/gem_metadata.rb
         123 d:/a/rubygems/rubygems/lib/rubygems/resolver/molinillo/lib/mol=
inillo/errors.rb
         124 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/set.rb
         125 d:/a/rubygems/rubygems/lib/rubygems/resolver/molinillo/lib/mol=
inillo/dependency_graph/action.rb
         126 d:/a/rubygems/rubygems/lib/rubygems/resolver/molinillo/lib/mol=
inillo/dependency_graph/add_edge_no_circular.rb
         127 d:/a/rubygems/rubygems/lib/rubygems/resolver/molinillo/lib/mol=
inillo/dependency_graph/add_vertex.rb
         128 d:/a/rubygems/rubygems/lib/rubygems/resolver/molinillo/lib/mol=
inillo/dependency_graph/delete_edge.rb
         129 d:/a/rubygems/rubygems/lib/rubygems/resolver/molinillo/lib/mol=
inillo/dependency_graph/detach_vertex_named.rb
         130 d:/a/rubygems/rubygems/lib/rubygems/resolver/molinillo/lib/mol=
inillo/dependency_graph/set_payload.rb
         131 d:/a/rubygems/rubygems/lib/rubygems/resolver/molinillo/lib/mol=
inillo/dependency_graph/tag.rb
         132 d:/a/rubygems/rubygems/lib/rubygems/resolver/molinillo/lib/mol=
inillo/dependency_graph/log.rb
         133 d:/a/rubygems/rubygems/lib/rubygems/resolver/molinillo/lib/mol=
inillo/dependency_graph/vertex.rb
         134 d:/a/rubygems/rubygems/lib/rubygems/resolver/molinillo/lib/mol=
inillo/dependency_graph.rb
         135 d:/a/rubygems/rubygems/lib/rubygems/resolver/molinillo/lib/mol=
inillo/state.rb
         136 d:/a/rubygems/rubygems/lib/rubygems/resolver/molinillo/lib/mol=
inillo/modules/specification_provider.rb
         137 d:/a/rubygems/rubygems/lib/rubygems/resolver/molinillo/lib/mol=
inillo/delegates/resolution_state.rb
         138 d:/a/rubygems/rubygems/lib/rubygems/resolver/molinillo/lib/mol=
inillo/delegates/specification_provider.rb
         139 d:/a/rubygems/rubygems/lib/rubygems/resolver/molinillo/lib/mol=
inillo/resolution.rb
         140 d:/a/rubygems/rubygems/lib/rubygems/resolver/molinillo/lib/mol=
inillo/resolver.rb
         141 d:/a/rubygems/rubygems/lib/rubygems/resolver/molinillo/lib/mol=
inillo/modules/ui.rb
         142 d:/a/rubygems/rubygems/lib/rubygems/resolver/molinillo/lib/mol=
inillo.rb
         143 d:/a/rubygems/rubygems/lib/rubygems/resolver/molinillo.rb
         144 d:/a/rubygems/rubygems/lib/rubygems/resolver/activation_reques=
t.rb
         145 d:/a/rubygems/rubygems/lib/rubygems/resolver/conflict.rb
         146 d:/a/rubygems/rubygems/lib/rubygems/resolver/dependency_reques=
t.rb
         147 d:/a/rubygems/rubygems/lib/rubygems/resolver/requirement_list.=
rb
         148 d:/a/rubygems/rubygems/lib/rubygems/resolver/stats.rb
         149 d:/a/rubygems/rubygems/lib/rubygems/resolver/set.rb
         150 d:/a/rubygems/rubygems/lib/rubygems/resolver/api_set.rb
         151 d:/a/rubygems/rubygems/lib/rubygems/resolver/composed_set.rb
         152 d:/a/rubygems/rubygems/lib/rubygems/resolver/best_set.rb
         153 d:/a/rubygems/rubygems/lib/rubygems/resolver/current_set.rb
         154 d:/a/rubygems/rubygems/lib/rubygems/resolver/git_set.rb
         155 d:/a/rubygems/rubygems/lib/rubygems/resolver/index_set.rb
         156 d:/a/rubygems/rubygems/lib/rubygems/resolver/installer_set.rb
         157 d:/a/rubygems/rubygems/lib/rubygems/resolver/lock_set.rb
         158 d:/a/rubygems/rubygems/lib/rubygems/resolver/vendor_set.rb
         159 d:/a/rubygems/rubygems/lib/rubygems/resolver/source_set.rb
         160 d:/a/rubygems/rubygems/lib/rubygems/resolver/specification.rb
         161 d:/a/rubygems/rubygems/lib/rubygems/resolver/spec_specificatio=
n.rb
         162 d:/a/rubygems/rubygems/lib/rubygems/resolver/api_specification=
.rb
         163 d:/a/rubygems/rubygems/lib/rubygems/resolver/git_specification=
.rb
         164 d:/a/rubygems/rubygems/lib/rubygems/resolver/index_specificati=
on.rb
         165 d:/a/rubygems/rubygems/lib/rubygems/resolver/installed_specifi=
cation.rb
         166 d:/a/rubygems/rubygems/lib/rubygems/resolver/local_specificati=
on.rb
         167 d:/a/rubygems/rubygems/lib/rubygems/resolver/lock_specificatio=
n.rb
         168 d:/a/rubygems/rubygems/lib/rubygems/resolver/vendor_specificat=
ion.rb
         169 d:/a/rubygems/rubygems/lib/rubygems/resolver.rb
         170 d:/a/rubygems/rubygems/lib/rubygems/source/git.rb
         171 d:/a/rubygems/rubygems/lib/rubygems/source/installed.rb
         172 d:/a/rubygems/rubygems/lib/rubygems/source/specific_file.rb
         173 d:/a/rubygems/rubygems/lib/rubygems/source/local.rb
         174 d:/a/rubygems/rubygems/lib/rubygems/source/lock.rb
         175 d:/a/rubygems/rubygems/lib/rubygems/source/vendor.rb
         176 d:/a/rubygems/rubygems/lib/rubygems/source.rb
         177 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/vendor/fileutils/lib/fileutils.rb
         178 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/vendored_fileutils.rb
         179 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/errors.rb
         180 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/environment_preserver.rb
         181 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/plugin/api.rb
         182 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/plugin.rb
         183 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/gem_helpers.rb
         184 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/match_platform.rb
         185 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/rubygems_ext.rb
         186 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/rubygems_integration.rb
         187 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/version.rb
         188 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/constants.rb
         189 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/current_ruby.rb
         190 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/build_metadata.rb
         191 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/x64-mingw32/enc/tr=
ans/single_byte.so
         192 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler.rb
         193 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/vendor/thor/lib/thor/command.rb
         194 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/vendor/thor/lib/thor/core_ext/hash_with_indifferent_a=
ccess.rb
         195 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/vendor/thor/lib/thor/error.rb
         196 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/vendor/thor/lib/thor/invocation.rb
         197 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/vendor/thor/lib/thor/nested_context.rb
         198 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/vendor/thor/lib/thor/parser/argument.rb
         199 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/vendor/thor/lib/thor/parser/arguments.rb
         200 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/vendor/thor/lib/thor/parser/option.rb
         201 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/vendor/thor/lib/thor/parser/options.rb
         202 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/vendor/thor/lib/thor/parser.rb
         203 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/vendor/thor/lib/thor/shell.rb
         204 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/vendor/thor/lib/thor/line_editor/basic.rb
         205 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/vendor/thor/lib/thor/line_editor/readline.rb
         206 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/vendor/thor/lib/thor/line_editor.rb
         207 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/vendor/thor/lib/thor/util.rb
         208 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/vendor/thor/lib/thor/base.rb
         209 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/vendor/thor/lib/thor.rb
         210 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/vendored_thor.rb
         211 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/friendly_errors.rb
         212 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/cli/common.rb
         213 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/settings.rb
         214 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/feature_flag.rb
         215 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/shared_helpers.rb
         216 d:/a/rubygems/rubygems/lib/rubygems/ext/builder.rb
         217 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/yaml_serializer.rb
         218 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/cli/config.rb
         219 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/cli/plugin.rb
         220 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/cli.rb
         221 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/vendor/thor/lib/thor/shell/basic.rb
         222 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/ui.rb
         223 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/ui/shell.rb
         224 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/ui/rg_proxy.rb
         225 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/cli/add.rb
         226 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/dependency.rb
         227 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/injector.rb
         228 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/settings/validator.rb
         229 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/ruby_dsl.rb
         230 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/dsl.rb
         231 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/source_list.rb
         232 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/source.rb
         233 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/source/rubygems.rb
         234 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/source/metadata.rb
         235 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/vendor/uri/lib/uri/version.rb
         236 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/vendor/uri/lib/uri/rfc2396_parser.rb
         237 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/vendor/uri/lib/uri/rfc3986_parser.rb
         238 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/vendor/uri/lib/uri/common.rb
         239 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/vendor/uri/lib/uri/generic.rb
         240 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/vendor/uri/lib/uri/file.rb
         241 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/vendor/uri/lib/uri/ftp.rb
         242 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/vendor/uri/lib/uri/http.rb
         243 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/vendor/uri/lib/uri/https.rb
         244 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/vendor/uri/lib/uri/ldap.rb
         245 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/vendor/uri/lib/uri/ldaps.rb
         246 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/vendor/uri/lib/uri/mailto.rb
         247 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/vendor/uri/lib/uri.rb
         248 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/vendored_uri.rb
         249 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/source/path.rb
         250 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/source/git.rb
         251 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/lockfile_parser.rb
         252 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/definition.rb
         253 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/lazy_specification.rb
         254 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/spec_set.rb
         255 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/vendor/molinillo/lib/molinillo/compatibility.rb
         256 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/vendor/molinillo/lib/molinillo/gem_metadata.rb
         257 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/vendor/molinillo/lib/molinillo/delegates/specificatio=
n_provider.rb
         258 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/vendor/molinillo/lib/molinillo/errors.rb
         259 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/vendor/molinillo/lib/molinillo/dependency_graph/actio=
n.rb
         260 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/vendor/molinillo/lib/molinillo/dependency_graph/add_e=
dge_no_circular.rb
         261 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/vendor/molinillo/lib/molinillo/dependency_graph/add_v=
ertex.rb
         262 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/vendor/molinillo/lib/molinillo/dependency_graph/delet=
e_edge.rb
         263 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/vendor/molinillo/lib/molinillo/dependency_graph/detac=
h_vertex_named.rb
         264 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/vendor/molinillo/lib/molinillo/dependency_graph/set_p=
ayload.rb
         265 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/vendor/molinillo/lib/molinillo/dependency_graph/tag.rb
         266 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/vendor/molinillo/lib/molinillo/dependency_graph/log.rb
         267 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/vendor/molinillo/lib/molinillo/dependency_graph/verte=
x.rb
         268 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/vendor/molinillo/lib/molinillo/dependency_graph.rb
         269 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/vendor/molinillo/lib/molinillo/state.rb
         270 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/vendor/molinillo/lib/molinillo/modules/specification_=
provider.rb
         271 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/vendor/molinillo/lib/molinillo/delegates/resolution_s=
tate.rb
         272 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/vendor/molinillo/lib/molinillo/resolution.rb
         273 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/vendor/molinillo/lib/molinillo/resolver.rb
         274 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/vendor/molinillo/lib/molinillo/modules/ui.rb
         275 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/vendor/molinillo/lib/molinillo.rb
         276 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/vendored_molinillo.rb
         277 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/resolver/spec_group.rb
         278 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/resolver.rb
         279 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/index.rb
         280 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/source/gemspec.rb
         281 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/dep_proxy.rb
         282 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/ruby_version.rb
         283 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/source/rubygems/remote.rb
         284 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/mirror.rb
         285 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/cgi/core.rb
         286 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/x64-mingw32/cgi/es=
cape.so
         287 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/cgi/util.rb
         288 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/cgi/cookie.rb
         289 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/cgi.rb
         290 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/vendor/connection_pool/lib/connection_pool/version.rb
         291 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/vendor/connection_pool/lib/connection_pool/monotonic_=
time.rb
         292 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/vendor/connection_pool/lib/connection_pool/timed_stac=
k.rb
         293 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/vendor/connection_pool/lib/connection_pool.rb
         294 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/vendor/net-http-persistent/lib/net/http/persistent/co=
nnection.rb
         295 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/vendor/net-http-persistent/lib/net/http/persistent/ti=
med_stack_multi.rb
         296 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/vendor/net-http-persistent/lib/net/http/persistent/po=
ol.rb
         297 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/vendor/net-http-persistent/lib/net/http/persistent.rb
         298 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/vendored_persistent.rb
         299 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/securerandom.rb
         300 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/x64-mingw32/date_c=
ore.so
         301 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/date.rb
         302 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/time.rb
         303 d:/a/rubygems/rubygems/lib/rubygems/request/http_pool.rb
         304 d:/a/rubygems/rubygems/lib/rubygems/request/https_pool.rb
         305 d:/a/rubygems/rubygems/lib/rubygems/request/connection_pools.rb
         306 d:/a/rubygems/rubygems/lib/rubygems/request.rb
         307 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/fetcher/base.rb
         308 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/worker.rb
         309 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/fetcher/compact_index.rb
         310 d:/a/rubygems/rubygems/bundler/tmp/1/gems/system/gems/bundler-=
2.2.0.dev/lib/bundler/fetcher/dependency.rb
         311 D:/rubyinstaller-2.7.1-1-x64/lib/ruby/2.7.0/base64.rb
         312 d:/a/rubygems/rubygems/lib/rubygems/s3_uri_signer.rb
         313 d:/a/rubygems/rubygems/lib/rubygems/uri_formatter.rb
       # $? =3D> 3
     # ./spec/commands/add_spec.rb:120:in `block (3 levels) in <top (requir=
ed)>'
     # ./spec/spec_helper.rb:104:in `block (4 levels) in <top (required)>'
     # ./spec/spec_helper.rb:104:in `block (3 levels) in <top (required)>'
     # ./spec/support/helpers.rb:335:in `block in with_gem_path_as'
     # ./spec/support/helpers.rb:349:in `without_env_side_effects'
     # ./spec/support/helpers.rb:331:in `with_gem_path_as'
     # ./spec/spec_helper.rb:101:in `block (2 levels) in <top (required)>'
     # ./spec/spec_helper.rb:73:in `block (2 levels) in <top (required)>'
     # ./spec/support/rubygems_ext.rb:90:in `load'
     # ./spec/support/rubygems_ext.rb:90:in `gem_load_and_activate'
     # ./spec/support/rubygems_ext.rb:18:in `gem_load'
```

Thanks!



-- =

https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=3Dunsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>