Issue #16949 has been updated by nagachika (Tomoyuki Chikanaga).

Backport changed from 2.5: REQUIRED, 2.6: REQUIRED, 2.7: REQUIRED to 2.5: REQUIRED, 2.6: REQUIRED, 2.7: DONE

ruby_2_7 3c55d93cf68b1a969b90b306de4dd8b88d74a2f2 merged revision(s) 7e289cdf3fed588b2d5a6973e29f9ff95cb8d76c.

----------------------------------------
Bug #16949: Psych tests failed with libyaml 0.2.5
https://bugs.ruby-lang.org/issues/16949#change-86143

* Author: znz (Kazuhiro NISHIYAMA)
* Status: Closed
* Priority: Normal
* Backport: 2.5: REQUIRED, 2.6: REQUIRED, 2.7: DONE
----------------------------------------
GitHub Actions CI failed on macOS, because Homebrew's [libyaml](https://github.com/Homebrew/homebrew-core/blob/90fecdb1745b65abb9883c2ad76b4e22e297b8ff/Formula/libyaml.rb) is 0.2.5 now.
So please backport commit:7e289cdf3fed588b2d5a6973e29f9ff95cb8d76c.


https://github.com/ruby/actions/runs/757794503?check_suite_focus=true#step:17:194
https://github.com/ruby/actions/runs/757791921?check_suite_focus=true#step:17:195
https://github.com/ruby/actions/runs/757793556?check_suite_focus=true#step:16:147



-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>