Issue #16920 has been updated by jaruga (Jun Aruga).


> I have never seen the test fail on Debian/Ubuntu aarch64. So use Ubuntu! (joke)

I love Debian. :) It's my pleasure when I spend time with people in Debian community.
 
> It is difficult to investigate the issue with no access to the machine...

Yeah, it makes sense.

> Can you reproduce the issue with ruby master? Can you try another Fedora+aarch64 environment? Can you measure how long the following command takes on the machine? (It takes less than one second on my machine, so I guess extending timeout would not solve the issue.)

Yes, I will try to reproduce the issue on the better way to inform you later, after my current focusing tasks.


----------------------------------------
Bug #16920: TestThread#test_signal_at_join fails on aarch64
https://bugs.ruby-lang.org/issues/16920#change-85870

* Author: jaruga (Jun Aruga)
* Status: Open
* Priority: Normal
* Backport: 2.5: UNKNOWN, 2.6: UNKNOWN, 2.7: UNKNOWN
----------------------------------------
I observed the following error on Ruby 2.7.1 building in Fedora aarch64 CI. It was just one time error. It does not always happen.

```
  1) Error:
TestThread#test_signal_at_join:
Timeout::Error: execution of assert_separately expired timeout (120 sec)
pid 2314088 killed by SIGABRT (signal 6) (core dumped)
| 
    /builddir/build/BUILD/ruby-2.7.1/test/ruby/test_thread.rb:1346:in `test_signal_at_join'
Finished tests in 1379.712832s, 15.2372 tests/s, 1972.9127 assertions/s.
```




-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>