Issue #16905 has been updated by extrowerk (Zolt=E1n Mizsei).


> parse.y file has been modified, or its timestamp changed at least.

I didn't edited that file and haven't changed the timestamp, so while your =
idea makes sense, i don't trust this error message at all, as this is from =
make, not from flex/bison, so it is way too generic error to be able to tel=
l whats going on here. Let's see what is in the debug output...

----------------------------------------
Bug #16905: Ruby required to build Ruby on Haiku?
https://bugs.ruby-lang.org/issues/16905#change-85773

* Author: extrowerk (Zolt=E1n Mizsei)
* Status: Open
* Priority: Normal
* ruby -v: not yet built, last running version 2.7.0p0
* Backport: 2.5: UNKNOWN, 2.6: UNKNOWN, 2.7: UNKNOWN
----------------------------------------
Building Ruby on Haiku results in the following error:

```
executable host ruby is required. use --with-baseruby option.
```

Build environment:

```
~> uname -a
Haiku shredder 1 hrev54197 May 14 2020 06:44:52 x86_64 x86_64 Haiku
```

Current recipe and patch set:
https://github.com/extrowerk/haikuports/tree/ruby_2.7.1/dev-lang/ruby

---Files--------------------------------
ruby_buildlog.txt (35.4 KB)


-- =

https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=3Dunsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>