Issue #16823 has been reported by Kulikjak (Jakub Kulik).

----------------------------------------
Bug #16823: Bundler related manual pages are corrupted
https://bugs.ruby-lang.org/issues/16823

* Author: Kulikjak (Jakub Kulik)
* Status: Open
* Priority: Normal
* ruby -v: ruby 2.6.5p114 (2019-10-01 revision 67812) [amd64-solaris2.11]
* Backport: 2.5: UNKNOWN, 2.6: UNKNOWN, 2.7: UNKNOWN
----------------------------------------
We recently found out that bundler related manual pages we get by building and installing ruby 2.6 (and as far as I can tell all newer versions as well) are corrupted (we are building with `--with-mantype=man`).

The reason is that, e.g. `ruby.1` (in the downloaded source) is not in the man format and must be passed through `mdoc2man`, bundle.1 is already valid man format, and passing it through `mdoc2man` corrupts it. The difference can be seen in the repo (those are different formats):
https://github.com/ruby/ruby/blob/master/man/ruby.1
https://github.com/ruby/ruby/blob/master/man/bundle.1

It seems like all man pages are always passed through `mdoc2man` no matter their content.

This happens to us on Solaris, although I cannot see how this can be isolated just to us (unless I am doing something wrong).  We solved this simply by overwriting corrupted manpages with those directly downloaded, but I guess that they should be correct right after the installation.




-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>