Issue #16760 has been reported by zenspider (Ryan Davis).

----------------------------------------
Bug #16760: backport #67305 / e39f7e64 to 2.6?
https://bugs.ruby-lang.org/issues/16760

* Author: zenspider (Ryan Davis)
* Status: Open
* Priority: Normal
* Backport: 2.5: UNKNOWN, 2.6: UNKNOWN, 2.7: UNKNOWN
----------------------------------------
https://bugs.ruby-lang.org/projects/ruby-master/repository/git/revisions/e39f7e64b73f0506def7adc88226d6821608da54

aka

https://github.com/ruby/ruby/commit/e39f7e64b73f0506def7adc88226d6821608da54

still crashes in the latest 2.6. Any chance it can be backported?

Repro:
`require "ripper/sexp"
rip = Ripper::SexpBuilderPP.new "_, _, _ = 1, *2, *3"
rip.yydebug = true
rip.parse
`

(seems to work on 2.5 just fine)



-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>