Issue #16488 has been updated by chdiza (Charles Diza).


That patch appears to have fixed the symptoms I see with Net/imap.

----------------------------------------
Bug #16488: 2.7 spews warnings about net/imap
https://bugs.ruby-lang.org/issues/16488#change-83811

* Author: chdiza (Charles Diza)
* Status: Closed
* Priority: Normal
* Assignee: 
* Target version: 
* ruby -v: ruby 2.7.0p0 (2019-12-25 revision 647ee6f091) [x86_64-darwin18]
* Backport: 2.5: UNKNOWN, 2.6: UNKNOWN, 2.7: REQUIRED
----------------------------------------
I just upgraded from 2.6.5 to 2.7.0.  Some of my scripts are now emitting warnings that weren't there before.  Eg., #16469.

Specifically in this report I want to complain that ruby 2.7 is issuing warnings about it's own net/imap library:

lib/ruby/2.7.0/Net/imap.rb:906: warning: Capturing the given block using Proc.new is deprecated; use `&block` instead



-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>