Issue #16483 has been updated by Eregon (Benoit Daloze).


`ruby-install` also uses `.tar.bz2` currently, so changing that would mean that existing releases would no longer work:
https://github.com/postmodern/ruby-install/blob/402cbdeaffb99d105ecd9b93c75828b32f0f382f/share/ruby-install/ruby/functions.sh#L4

Not sure about RVM.

----------------------------------------
Misc #16483:  How about stopping new *.tar.bz2 releases?
https://bugs.ruby-lang.org/issues/16483#change-83677

* Author: znz (Kazuhiro NISHIYAMA)
* Status: Open
* Priority: Normal
* Assignee: 
----------------------------------------
Current ruby releases generate `*.tar.gz`, `*.tar.bz2`, `*.tar.xz`, and `*.zip`.
But I think we can stop generating `*.tar.bz2`.

I think `*.tar.bz2` are less merit.
For better size, `*.tar.xz` exist.
For better compatibility, `*.tar.gz` and `*.zip` exist.

I check some programming languages source package archives.

- https://jdk.java.net/13/ tar.gz zip
- https://gcc.gnu.org/mirrors.html tar.gz tar.xz
- https://www.python.org/downloads/source/ tgz tar.xz
- https://nodejs.org/dist/v12.14.0/ tar.gz tar.xz (and 7z zip for win)
- https://www.perl.org/get.html tar.gz
- https://www.php.net/downloads.php tar.bz2 tar.gz tar.xz

`tar.bz2` are rare.

How about stopping `*.tar.bz2` since next release?

(I know [ruby-build](https://github.com/rbenv/ruby-build) use `*.tar.bz2`. And it can use `*.tar.gz`)



-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>