Issue #16444 has been updated by y-yagi (Yuji Yaginuma).


Thanks for your feedback. OK. I understood that too late to discuss and a message is as expected.   

I think it would be good if the message could be configurable, but I will also consider expanding the options on the library side. Thanks.


----------------------------------------
Misc #16444: What is the reason for the warning of IRB? 
https://bugs.ruby-lang.org/issues/16444#change-83331

* Author: y-yagi (Yuji Yaginuma)
* Status: Open
* Priority: Normal
* Assignee: 
----------------------------------------
Ruby 2.7 always shows a warning when starting IRB. Why is this necessary? 

Of course, ways to suppress the warning have been suggested. 
However, libraries that extend IRB, such as `rails console` and `aruba`, may not receive arguments equivalent as IRB.
In this case, trying to run as suggested in this proposal(e.g. run `rails console` with `--legacy` argument)  will result in an error. I think this can be confusing for users.

If have not major known issues, I think we can keep the current behavior without warning. On the other hand, if there is already an issue, isn't the better for the old behavior by default?

Thanks.



-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>