Hello Eric,

Sorry for the delay.

I've merged your patch (https://github.com/ruby/curses/commit/a9b9db9),
and will release curses.gem.

Thank you.

On Mon, 16 Dec 2019 03:10:55 +0000
Eric Wong <normalperson / yhbt.net> wrote:
> [0 text/plain; charset=utf-8]
> > https://bugs.ruby-lang.org/issues/16131
> 
> "curses" gem needs to be updated, I emailed Shugo about it a few
> weeks ago but no response.  See attached patch.
> (I don't use JavaScript or agree to GitHub Terms of Service).
> 
> For C extensions, I recommend just deprecating with a
> compile-time warning in C, NOT runtime.  Regular Ruby users
> installing C ext gems may not be able to do anything about it.
> [1 text/x-diff; charset=utf-8]
> [2 text/plain; charset=us-ascii]
> 
> Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
> <http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>