Issue #16431 has been reported by vo.x (Vit Ondruch).

----------------------------------------
Bug #16431: Optionally load did_you_mean (and RubyGems)
https://bugs.ruby-lang.org/issues/16431

* Author: vo.x (Vit Ondruch)
* Status: Open
* Priority: Normal
* Assignee: 
* Target version: 
* ruby -v: ruby 2.7.0dev (2019-12-10 master af11efd377) [x86_64-linux]
* Backport: 2.5: UNKNOWN, 2.6: UNKNOWN
----------------------------------------
I just have opened PR [1], which allows Ruby to run when did_you_mean is not available. As I previously discussed in #16427, there are cases when speed, memory, disk or network bandwidth is a concern and did_you_mean is not useful for runtime. This is especially useful when Ruby is installed via packaging systems of (Linux) distributions.

The PR is split into 4 commits, because since I was there, I prepared similar changes to RubyGems.



[1]: https://github.com/ruby/ruby/pull/2764



-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>