Issue #16392 has been updated by MSP-Greg (Greg L).

Subject changed from test-all failure MinGW - TestEncoding#test_nonascii_library_path to test-all failure Windows - TestEncoding#test_nonascii_library_path

I ran Actions CI and saved the vc140 build as an artifact:

ruby 2.7.0dev (2019-12-12T23:58:42Z master 1140625cd3) [x64-mswin64_140]

Using it locally, had the same error as MinGW.

```
  1) Failure:
TestEncoding#test_nonascii_library_path [C:/Greg/GitHub/ruby/test/ruby/test_encoding.rb:128]:
Exception(LoadError) with message matches to /\[Bug #16382\]/.
[LoadError] exception expected, not #<SystemStackError: stack level too deep>.
```

Note that it seems to pass when run on Appveyor...

----------------------------------------
Bug #16392: test-all failure Windows - TestEncoding#test_nonascii_library_path
https://bugs.ruby-lang.org/issues/16392#change-83127

* Author: MSP-Greg (Greg L)
* Status: Open
* Priority: Normal
* Assignee: 
* Target version: 
* ruby -v: ruby 2.7.0dev (2019-12-02T23:51:50Z master 14a17063a1) [x64-mingw32]
* Backport: 2.5: UNKNOWN, 2.6: UNKNOWN
----------------------------------------
ruby-loco build failed, so ran the test locally using runner.rb.  Failed on both of the below builds.  The new test is valid, but the fix in 14a17063a1 doesn't seem to be working...

```
ruby 2.7.0dev (2019-12-02T23:51:50Z master 14a17063a1) [x64-mingw32]  (Fixed stack overflow [Bug #16382])
ruby 2.7.0dev (2019-12-02T08:17:41Z master a47d6c256f) [x64-mingw32]  (Fix random failure on getusage-missing environments)
```

```
  1) Failure:
TestEncoding#test_nonascii_library_path [C:/Greg/GitHub/ruby/test/ruby/test_encoding.rb:128]:
Exception(LoadError) with message matches to /\[Bug #16382\]/.
[LoadError] exception expected, not #<SystemStackError: stack level too deep>.
```



-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>