Issue #16385 has been reported by itkin (nicolas paon).

----------------------------------------
Bug #16385: Segmentation fault when running a rails app with puma
https://bugs.ruby-lang.org/issues/16385

* Author: itkin (nicolas paon)
* Status: Open
* Priority: Normal
* Assignee: 
* Target version: 
* ruby -v: 2.5.1
* Backport: 2.5: UNKNOWN, 2.6: UNKNOWN
----------------------------------------
got a new machine and after reinstalling a dev env, i cannot run locally a functional rails app
seems to be linked to puma since the app can be booted and the database can be accessed from the rails console.

If somebody more competent than me could take a quick look this is surely a huge setup mistake on my part (fact is that i don't see it)

NB : i set up the macbook with disk encryption in a first time, then (trying to blindly fix the issue) reverted this option and reinstalled rvm . 


osx 10.15.1
xcode 11.2.1
rvm 1.29.9 (latest)
ruby 2.5.1 
postgres (PostgreSQL) 12.1

gems : 
rails 5.2.0
puma 3.11.4
pg 0.18.4

the error trace (the complete trace is attached) : 

`/Users/nicolas/.rvm/gems/ruby-2.5.1@softcorner2/gems/activerecord-5.2.0/lib/active_record/connection_adapters/abstract/connection_pool.rb:299: [BUG] Segmentation fault at 0x0000000000000110
ruby 2.5.1p57 (2018-03-29 revision 63029) [x86_64-darwin19]

-- Crash Report log information --------------------------------------------
   See Crash Report log file under the one of following:                    
     * ~/Library/Logs/DiagnosticReports                                     
     * /Library/Logs/DiagnosticReports                                      
   for more details.                                                        
Don't forget to include the above Crash Report log file in bug reports.     

-- Control frame information -----------------------------------------------
c:0005 p:---- s:0020 e:000019 CFUNC  :sleep
c:0004 p:0007 s:0015 e:000014 BLOCK  /Users/nicolas/.rvm/gems/ruby-2.5.1@softcorner2/gems/activerecord-5.2.0/lib/active_record/connection_adapters/abstract/connecti [FINISH]
c:0003 p:---- s:0012 e:000011 CFUNC  :loop
c:0002 p:0006 s:0008 e:000007 BLOCK  /Users/nicolas/.rvm/gems/ruby-2.5.1@softcorner2/gems/activerecord-5.2.0/lib/active_record/connection_adapters/abstract/connecti [FINISH]
c:0001 p:---- s:0003 e:000002 (none) [FINISH]

-- Ruby level backtrace information ----------------------------------------
/Users/nicolas/.rvm/gems/ruby-2.5.1@softcorner2/gems/activerecord-5.2.0/lib/active_record/connection_adapters/abstract/connection_pool.rb:298:in `block in run'
/Users/nicolas/.rvm/gems/ruby-2.5.1@softcorner2/gems/activerecord-5.2.0/lib/active_record/connection_adapters/abstract/connection_pool.rb:298:in `loop'
/Users/nicolas/.rvm/gems/ruby-2.5.1@softcorner2/gems/activerecord-5.2.0/lib/active_record/connection_adapters/abstract/connection_pool.rb:299:in `block (2 levels) in run'
/Users/nicolas/.rvm/gems/ruby-2.5.1@softcorner2/gems/activerecord-5.2.0/lib/active_record/connection_adapters/abstract/connection_pool.rb:299:in `sleep'

`

---Files--------------------------------
crash-trace.txt (494 KB)
ruby_2019-12-02-133809_toto.crash (70.3 KB)


-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>