Issue #16346 has been reported by y_kojima (Yohei Kojima).

----------------------------------------
Misc #16346: Confusing macro name: RUBY_MARK_NO_PIN_UNLESS_NULL
https://bugs.ruby-lang.org/issues/16346

* Author: y_kojima (Yohei Kojima)
* Status: Open
* Priority: Normal
* Assignee: 
----------------------------------------
function `rb_gc_mark_no_pin` is renamed to `rb_gc_mark_movable` in the commit `aac4d9d6c7e6b6b0742f3941b574f6006ccb5672`.
But macro `RUBY_MARK_NO_PIN_UNLESS_NULL` is not renamed then.

Now, `RUBY_MARK_NO_PIN_UNLESS_NULL` calls `rb_gc_mark_movable`; this is a bit confusing.
So I suggest renaming `RUBY_MARK_NO_PIN_UNLESS_NULL` to `RUBY_MARK_MOVABLE_UNLESS_NULL` like this patch.

---Files--------------------------------
p.patch (2 KB)


-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>