On Nov 16, 2006, at 6:47 AM, Hugh Sasse wrote:

> I've been thinking about how version numbers are restricting what  
> we can do.
> We are having difficulties releasing 1.8.x because x can only be in  
> [6789]
> before we run out of numbers.  Similarly, 1.9 will be the upper  
> limit of
> the 1.y series.

So what if we run out of numbers?

$ ruby -e 'p %w[1.8.0 1.8.8 1.8.9 1.8.a 1.8.b 1.8.z].sort'
["1.8.0", "1.8.8", "1.8.9", "1.8.a", "1.8.b", "1.8.z"]

> [...]
>
> Does the above seem reasonable?  Is it even sane :-) ?

I think it will be time to worry about that when we get to 1.x.x.

-- 
Eric Hodel - drbrain / segment7.net - http://blog.segment7.net
This implementation is HODEL-HASH-9600 compliant

http://trackmap.robotcoop.com