Issue #16271 has been reported by jeremyevans0 (Jeremy Evans).

----------------------------------------
Bug #16271: Cannot build taglib-ruby gem on ruby-2.7.0-preview2
https://bugs.ruby-lang.org/issues/16271

* Author: jeremyevans0 (Jeremy Evans)
* Status: Open
* Priority: Normal
* Assignee: shyouhei (Shyouhei Urabe)
* Target version: 
* ruby -v: ruby 2.7.0preview2 (2019-10-22 master 02aadf1032) [x86_64-openbsd]
* Backport: 2.5: DONTNEED, 2.6: DONTNEED
----------------------------------------
Attempting to build the taglib-ruby gem on ruby-2.7.0-preview2 fails with error messages such as:

```
taglib_base_wrap.cxx:2101:9: error: no matching function for call to 'rb_rescue'
    if (rb_rescue(RUBY_METHOD_FUNC(SWIG_AUX_NUM2ULONG), (VALUE)a, RUBY_METHOD_FUNC(SWIG_ruby_failed), 0) != Qnil) {
            ^~~~~~~~~
            /usr/local/include/ruby-2.7/ruby/ruby.h:1989:7: note: candidate function not viable: no known conversion from 'VALUE (VALUE *)' (aka 'unsigned long (unsigned long *)') to 'VALUE (*)(VALUE)' (aka 'unsigned long (*)(unsigned long)') for 1st argument
            VALUE rb_rescue(VALUE(*)(VALUE),VALUE,VALUE(*)(VALUE,VALUE),VALUE);
```

I believe this is related to the CXX/ANYARGS changes made between ruby-2.7.0-preview1 and preview2.  I was not aware these were expected to cause backwards compatibility issues, which is why I'm submitting the bug report here.

I believe taglib-ruby uses code generated via SWIG.  I'm not sure if SWIG needs to be adjusted, or if the issue is related to the use of SWIG.

This may be a problem in the gem and not in our CXX handling.  In that case, please let me know and I will post an issue in the gem's tracker.



-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>